[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian and wol on Buffalo Linkstation WXL

hello everyone

I have an old Buffalo Linkstation Duo (WXL), that now I would lie to use as a backup for my new NAS
I've bumped into RogerShimizu's presentation at https://miniconf.debian.or.jp/assets/files/Debian%20Installer%20for%20Buffalo%20Linkstation%20NAS.pdf, in order to update a bit the system with a fresh new debian install; I followed it and I now have a running Debian system , but:
  • the only way to shutdown the unit is to put the physical button in the off position, otherwise both poweroff and shutdown commands lead to a reboot of the unit
  • wakeonlan is not available:
    • ethtool responds "Supports Wake-on: d", and trying to set it ends in:ï¿œ "Cannot set new wake-on-lan settings: Operation not supported"

a@debian:~$ sudo ethtool eth0
Settings for eth0:
ᅵᅵ ᅵSupported ports: [ TP MII ]
ᅵᅵ ᅵSupported link modes:ᅵᅵ 10baseT/Half 10baseT/Full
ᅵᅵ ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 100baseT/Half 100baseT/Full
ᅵᅵ ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 1000baseT/Full
ᅵᅵ ᅵSupported pause frame use: Symmetric Receive-only
ᅵᅵ ᅵSupports auto-negotiation: Yes
ᅵᅵ ᅵAdvertised link modes:ᅵ 10baseT/Half 10baseT/Full
ᅵᅵ ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 100baseT/Half 100baseT/Full
ᅵᅵ ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 1000baseT/Full
ᅵᅵ ᅵAdvertised pause frame use: No
ᅵᅵ ᅵAdvertised auto-negotiation: Yes
ᅵᅵ ᅵLink partner advertised link modes:ᅵ 10baseT/Half 10baseT/Full
ᅵᅵ ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 100baseT/Half 100baseT/Full
ᅵᅵ ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 1000baseT/Full
ᅵᅵ ᅵLink partner advertised pause frame use: Symmetric Receive-only
ᅵᅵ ᅵLink partner advertised auto-negotiation: Yes
ᅵᅵ ᅵSpeed: 1000Mb/s
ᅵᅵ ᅵDuplex: Full
ᅵᅵ ᅵPort: MII
ᅵᅵ ᅵPHYAD: 8
ᅵᅵ ᅵTransceiver: internal
ᅵᅵ ᅵAuto-negotiation: on
ᅵᅵ ᅵSupports Wake-on: d
ᅵᅵ ᅵWake-on: d
ᅵᅵ ᅵLink detected: yes
obviously with the original buffalo firmware, it worked!

I've tried, under Roger's suggestion, to add "marvell" to /etc/initramfs-tools/modules, but nothing changed: it seems that the NIC is not enable for wakeonlaᅵ (even if it was, of course)

now I'm wondering if it could be a driver issue, and if is there any other module that can be used instead of the mv643xx_eth

a@debian:~$ sudo dmesg |grep eth
[ᅵᅵᅵ 0.022487] [Firmware Info]: /ocp@f1000000/ethernet-controller@76000/ethernet1-port@0: local-mac-address is not set
[ᅵᅵ 20.475943] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
[ᅵᅵ 20.593063] mv643xx_eth_port mv643xx_eth_port.0 eth0: port 0 with MAC address 00:24:a5:47:96:af
[ᅵᅵ 34.213593] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ᅵᅵ 36.875031] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[ᅵᅵ 36.885480] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
and now I'm stuck here... My idea to use this old unit as a "semi-remote" (in the same LAN)backup of the new NAS doesn't work, if I'm not able to switch it off and on when neededl

any suggestion?

thanks in advance


Reply to: