[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: need sd card backup on r-pi-3b

On Saturday 23 September 2017 00:12:11 Alan Corey wrote:

> I don't know, it just works for me.  Even over VNC, I just tried it
> from vncviewer on an OpenBSD machine.  The "copy from device" is blank
> until I click the down arrow on it, then it finds /dev/mmcblk0.  I'm
> running it on the machine that's running tightvncserver which I'm
> logged into.  I use VNC a lot, I've maybe gotten a remote X connection
> to work a couple times years ago.  The wrong authentication thing,
> have you looked at the xhost man page?  I remember sometimes you have
> to do
>   xhost +localhost
> and any remote machines you want to connect from have to be added in a
> similar way.  With vnc you just need to set up the password with
> vncpasswd.  Then you type like tightvncserver in a terminal window to
> start it.  From the remote machine you type vncviewer and the IP or
> machine name:display.  Server and client software names may be
> different from mine, you need one of each.  I've even had an android
> vnc client that worked over wifi from a phone.  Wheezy or Jessie
> shouldn't matter, remote X has been around for like 35 years.  Since
> dialup modems have been around.
> Why are you at localhost:11?  Usually it's localhost:0.  Are you
> logged in from 10 other machines too or something?  Try 'echo
> $DISPLAY' and see what it says, mine says :0.  Ooops, the Pi says
I am logged in as "ssh -Y pi@picnc" with my usual user passwd.
The 1st such login reports:
pi@picnc:~ $ echo $DISPLAY

And a 2nd such login reports:
pi@picnc:~ $ echo $DISPLAY

xhost + has been executed on all machines.

> :1.0, OpenBSD says :0.  vnc display numbers are similar but not
> compatible as far as I know with X  connections.
> I just did (on a pi):
> pi2# xhost +192.168.7 and got
> 192.168.7 being added to access control list
> But when I try xterm -display in an ssh window to the pi
> from openbsd I get crap about running as root and it refuses.  There
> might be a way to put a username in there like you can ssh to
> user@machine or in mc you cd to ftp://user:pass@machine.  15 years ago
> my girlfriend at the time thought it was cool so we did it a couple
> times.  VNC I've used a lot more.  Daily just about.  Sometime it's
> open for a week at a time.
Months at a time here, but anytime I need to do anything as root that 
involves more than ncurses graphics, I have to go to the machine and do 
it there, and its a stand-up job with very poor gfx due to the pi's 
limited color pallate.  Hard on the old mans back, and the pain 
distracts me from the job I went there to do. Not your fault, but 
somebody apparently decided it was a security risk, so they have 
restricted things like running synaptic-pkexec to a local keyboard and 
monitor only thing. What it really is is a right pain in the old mans 
back and legs.

So, tell me more about vnc please.  If it can bypass this crap, and let 
me do gfx stuff as root using sudo, I'll see if I can make it work.

The puzzling part is that the limited colors but otherwise full power of 
the pi's gfx engine can run LinuxCNC over this X11 connection well 
except for video rendering speed, its slowed to around 3 or 4 fps over 
the network connection. I have lcnc configured such that I can power it 
up and run it from here, but if I see a potential crash about to occur 
in the backplot, its already happened at the machine. Thats hard on 
tooling as it usually will break the tool or its carbide insert, at 
several dollars a copy, so that isn't done.

> On 9/22/17, Gene Heskett <gheskett@shentel.net> wrote:
> > On Friday 22 September 2017 22:14:48 Alan Corey wrote:
> >> I thought piclone was great for that.  With a couple manual edits
> >> you can even clone an sd to a hard drive.

I'd love to do that too as I've a terrabyte drive that is only being used 
for swap plugged into the pi. I have 2 other partitions setup, and I 
think copied, but the pi is unable to find it and boot from it.

> > I have never been able to make it work. No helpfull manpage, nor
> > does it have a help option that I've found other than what you get
> > by clicking on help when run as 1st user. Run as 1st user, it cannot
> > find a target device.  The help there says "the card its booted
> > from" as if it might be a fixed address to pull from, in which case
> > why the ghosted out source selection buttons?
> >
> > And of course I cannot do anything from here as root via sudo
> > because localhost:11 is not a valid x11 screen.
> >
> > I have asked how to fix that, several times, but without a solution.
> > That pi is the only jessie machine, 3 other wheezy machines on this
> > network Just Work(TM) in the exact same situation.  Whats with
> > jessie that it won't?  Or with wheezy if the refusal is here?
> >
> > From that terminal screen on this wheezy box:
> > pi@picnc:~ $ sudo piclone
> > X11 connection rejected because of wrong authentication.
> >
> > (piclone:2001): Gtk-WARNING **: cannot open display: localhost:11.0
> > pi@picnc:~ $
> >
> > Thanks Alan.
> >
> >> On 9/22/17, Gene Heskett <gheskett@shentel.net> wrote:
> >> > Greetings;
> >> >
> >> > Trying to dd a copy of the micro-sd card the pi-3b is booting
> >> > from, to another micro-sd card in a usb reader/writer, and
> >> > winding up with nothing but an empty lost+found directory on it.
> >> >
> >> > Obviously some sort of a syntax error, but it still takes the pi
> >> > several hours to do it, with the traffic led on the reader/writer
> >> > showing continuous activity.
> >> >
> >> > Is there another way/util that actually works for making verbatim
> >> > backups of these limited lifetime sd cards?
> >> >
> >> > Thanks.
> >> >
> >> > Cheers, Gene Heskett
> >> > --
> >> > "There are four boxes to be used in defense of liberty:
> >> >  soap, ballot, jury, and ammo. Please use in that order."
> >> > -Ed Howdershelt (Author)
> >> > Genes Web page <http://geneslinuxbox.net:6309/gene>
> >
> > Cheers, Gene Heskett
> > --
> > "There are four boxes to be used in defense of liberty:
> >  soap, ballot, jury, and ammo. Please use in that order."
> > -Ed Howdershelt (Author)
> > Genes Web page <http://geneslinuxbox.net:6309/gene>

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

Reply to: