[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Wheezy on DreamPlug: Unable to make the system bootable

On Sat, 2013-08-31 at 10:57 +0200, Paul Kocialkowski wrote:
> Hello there! I'm new to this list, and I'm the happy owner of a
> Globalscale Dreamplug, that I intend to use as a home server, with
> Debian Wheezy.
> First, I followed the instructions[1] I could find to properly prepare
> the DreamPlug (that is, updating U-Boot to the Debian/DENX version), and
> then I could start the installer from tftp boot. It all started nicely,
> but every single time I tried the installation (which is about 4 times
> now), it hanged on "Installed u-boot-tools", in the "making the system
> bootable" part. It stayed there for about half an hour before I reset
> the plug (the longest I waited).

I downloaded: 
7bc3332ed880606509511c7b4b439266  uImage
6afad330c6d75296255782e79226c94a  uInitrd

Marvell>> set autoload no
Marvell>> dhcp
Marvell>> setenv serverip
Marvell>> tftpboot 0x00800000 dreamplug/uImage
Marvell>> tftpboot 0x01100000 dreamplug/uInitrd
Marvell>> setenv bootargs console=ttyS0,115200n8 base-installer/initramfs-tools/driver-policy=most
Marvell>> bootm 0x00800000 0x01100000

Then I selected all the defaults apart from using a local apt proxy and
my passwords.

I didn't see the problem you saw and the installation completed ok,
through to rebooting into the new installation..

Did you select any non-default options as you went through the

When it hangs do you get a cancel or go back button which would allow
you to access the installer syslog? Perhaps if you force a reboot at
this point and boot in rescue mode (add "rescue/enable=true" to the
bootargs) then you can access the target rootfs and find the instller
logs in /var/log/installer?

Are you installing to internal or external MMC?

It shouldn't matter (if your kernel is booting you don't have the buggy
one), but which u-boot do you have? Mine reports:
        U-Boot 2012.04.01 (Jun 01 2012 - 02:17:08)

> I also tried to take
> daily debian-installer images but at this point, the ethernet hardware
> of the DreamPlug wasn't recognized, so there was no way for me to
> proceed with the installation.

Oh dear, which daily image did you use?


Reply to: