[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing Wheezy on DreamPlug: Unable to make the system bootable

Hello there! I'm new to this list, and I'm the happy owner of a
Globalscale Dreamplug, that I intend to use as a home server, with
Debian Wheezy.

First, I followed the instructions[1] I could find to properly prepare
the DreamPlug (that is, updating U-Boot to the Debian/DENX version), and
then I could start the installer from tftp boot. It all started nicely,
but every single time I tried the installation (which is about 4 times
now), it hanged on "Installed u-boot-tools", in the "making the system
bootable" part. It stayed there for about half an hour before I reset
the plug (the longest I waited).

So it seems to me like there is something wrong with the Debian
installer. The images I used were [2] and [3]. I also tried to take
daily debian-installer images but at this point, the ethernet hardware
of the DreamPlug wasn't recognized, so there was no way for me to
proceed with the installation.

In the end, I started the installer in expert mode (priority=low added
to the cmdline) and intentionally skipped the "making the system
bootable" part, which obviously resulted in the uImage and uInitrd not
being created. I had to retrieve the generated initramfs and vmlinuz to
my computer (using ssh/scp with the installer), then apply the
flash-kernel script to make it generate the u-boot images, then boot
them via tftp, to finally be able to boot Debian, install flash-image
and u-boot-tools and be able to properly generate the u-boot images.
Then it booted.

How come I have to face such a situation with the stable installer
images? Am I the only one experiencing this, and if so, any clue why?

[1]: http://www.cyrius.com/debian/kirkwood/sheevaplug/

Reply to: