[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: System crashes on USB connection

That's right, I don't have a serial console.

If the USB hub is really reset, then this might be an explanation. As 'lsusb' suggests, the QNAP internally only seems to have one USB hub:

root@NAS:~# lsusb
Bus 001 Device 003: ID 0781:5571 SanDisk Corp.
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The device has 4 ports, of which 3 are on the back and one is on the front. The "SanDisk Corp." is my USB flash drive with the OS installed on it, connected to one of the backside ports. The other ports were not occupied when I issued the above command.

So what would be the most sensible thing to try? Connecting the printer to the front port instead of one of the back ports?
When doing this I will also try to use another cable as I'm currently using an extension cable (2 meters I think).

But one thing to add: I have been using this very printer, this very NAS and this very set of cables for approx. one year every day using the original QNAP firmware. And I never had a crash or problems printing using the NAS and CUPS.

-------- Original-Nachricht --------
Betreff: RE: System crashes on USB connection
Datum: Mon, 26 Nov 2012 15:00:44 -0000
Von: Paul Kench <paulkench@yahoo.co.uk>
An: 'Christoph Zep' <debian-arm@quantentunnel.de>, <debian-arm@lists.debian.org>

>On my Kirkwood NAS (Netgear Stora) running Wheezy, I have a hub connected, I
>find that plugging devices into the hub in the 'wrong' port resets it. This
>doesn't affect my '/' as it's on the SATA disk. Do you know if the ports on
>your QNAP are a hub internally?
>I find the USB resets are port order dependent, if you can try swapping the
>root fs and the printer, it might work.
>I take it you don't have a serial console?

>> -----Original Message-----
>> From: Christoph Zep [mailto:debian-arm@quantentunnel.de]
>> Sent: 25 November 2012 23:54
>> To: debian-arm@lists.debian.org
>> Subject: System crashes on USB connection
>> Hi everyone,
>> I installed Debian on a USB flash drive on my QNAP TS-419p+(Kirkwood)
>> inserted into the lowest backside USB port.Everything's been working
>> very smoothly until I tried to connect my printer to the NAS (also via
>> USB). Via SSH the NAS reacted with the same error to every command as
>> soon as the printer was connected:
>> -bash: /bin/dmesg: Input/output error
>> Upon manual power off (button on the NAS) and reboot, the system took a
>> very long time to come up and finally booted. Since then, the system
>> boots quickly againbut I don't know how to get my printer working.
>> Thanks for any suggestions,
>> Christoph
>> --
>> To UNSUBSCRIBE, email to debian-arm-REQUEST@lists.debian.org
>> with a subject of "unsubscribe". Trouble? Contact
>> listmaster@lists.debian.org
>> Archive: 50B2AF81.7000604@quantentunnel.de">http://lists.debian.org/50B2AF81.7000604@quantentunnel.de

Reply to: