[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Failing to boot from sd card

So just as an update...

I think the problem is the with the selection of packages at the time of the installation.

I selected the "web server", "print server" "ssh server" & "database". I tried these same selections two times both from debian ftp. All those times, the installation went through but when trying to boot, fsck failed and then the installation hung..But I didn't know the package selection was the problem, until I tried with just the default selection of core utilities, and that worked fine.

During the installation phase, I didnt see any error's about any packages being unavailable.... As I said before, once i only selected the core utilities it all worked fine.

If someone can confirm, if the other packages are working for them...maybe I got unlucky while fetching them!?


On Wed, Jul 21, 2010 at 12:19 PM, Shiva Bhattacharjee <shivajee@gmail.com> wrote:

On Wed, Jul 21, 2010 at 11:51 AM, Martin Michlmayr <tbm@cyrius.com> wrote:

Yes, I uploaded fixed installer images last evening.

Thanks Martin. That's what I suspected. 

The boot process looks fine to me but obviously the "login" prompt is
missing.  Here is what I think happened: your SheevaPlug reset just
before the installer was done.  This would explain the filesystem
check (the partitions weren't unmounted properly) and the lack of
login prompt (login on the serial console gets activated towards the
end of the instalation).

That could be a possible explanation. I let it run over night during the installation, but while connected to the serial port the host machine might have gone to sleep. I am not sure, if it sends an interrupt while it happens. But that could explain why the sheevaplug might quit during the installation. Thanks for the suggestion, I will retry the installation.

Martin Michlmayr

Reply to: