[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wxWidgets-2.8 completely broken on lenny arm

[ please CC your replies because I'm not subscribed to the list ]


I'm a co-maintainer of the amule[0] package.

While investigating on #537733 (amule-daemon crashes with Segmentation
Fault on starting[1]) I discovered that all reverse dependencies of the
wxWidgets-2.8 library are broken on arm, e.g. filezilla and poedit fail
at startup with segfaults.

Unfortunately, this bug seems not to be related to the wxWidgets
library itself but rather to the compiler, i.e. the default gcc version
in lenny which is 4.3.2.
In fact, building wxWidgets-2.8 with gcc-4.1 seems to fix the issues
with the applications I tested so far (amule, filezilla, poedit).

Unfortunately (again), this _could_ be just the tip of the iceberg,
since other applications too seems to be affected by the "segfaults at
startup" sindrome, such as audacious, qbittorrent and maybe others.

To the best of my knowledge and experience, the only bug which seems to
be related to this kind of issue could be #487406, which was filed and
forwarded upstream a lot of time ago[2].

Any confirmation, help and comment would be really appreciated!

[0] http://packages.qa.debian.org/a/amule.html
[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=537733
[2] http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38642

Cristian Greco
GPG key ID: 0xCF4D32E4

Attachment: signature.asc
Description: PGP signature

Reply to: