[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Net booting iop32x with RedBoot

> I tried booting the kernel that's already on the flash, and in its
> boot logs (before it dies due to lack of root fs), I have this line:
> Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
> ttyS0 at MMIO 0xfe800000 (irq = 30) is a 16550A
> How can I tell if that driver is in the vmlinuz that I got from the debian site?

Ok, now I've tried the kernel that you made for some other board
(http://www.rtp-net.org/ss4000e/zImage_2633_iop32x_defconfig), and it
appears to nearly work, but not quite.  I get past the Uncompressing
Linux bit, to "done, booting the kernel.", and then it starts giving
me garbage characters, as though it doesn't understand the rate of the
serial port.  My session looks like this:

RedBoot> load -r -v -b 0x00180000 zImage_2633_iop32x_defconfig
Using default protocol (TFTP)
Raw file loaded 0x00180000-0x003f1aaf, assumed entry at 0x00180000
RedBoot> exec -c "console=ttyS0,115200n8"
Using base address 0x00180000 and length 0x00271ab0
The boot tags are located at 0xA0000100
Booting the kernel...
Uncompressing Linux... done, booting the kernel.
�9H8    {.)     (       +�.��0P 88)�    (q.y.P� (.(.9y  �(.qR蕚�(

I did set the rate on the serial port when booting, so I don't know if
it's somehow using the wrong driver for the serial port it's attached
to, or if I'm somehow setting the rate wrong.  I'll keep playing with
it anyhow, and see what I can come up with.  Any suggestions would be
welcome, of course.  Also, that final line keeps changing, so there is
output being written to the terminal, it's just invalid output.  I
think that kernel can boot my hardware, if only I could get a
reasonable output from it.

Reply to: