[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Thecus N2100 installation fails

> Hi All,
> I bought an used N2100 at the bay, and tried to install Debian,
> following Martin Michlmayr's great instructions, but I fail.
> After uploading the Debian firmware it prompts for the reboot, but
> does not come up again. Also, the LEDs stop flashing after Redboot
> tried to load the OS (that's a guess in fact).

Thats fine, its a sign that the kernel indeed boots, but seems to stuck
somewhere else, for example the network config?

First thought is that LAN is not up or you expecting another IP address.
Is the network LED blinking during boot? Can you use a network sniffer to
see if dhcp packages are exchanged? Nmap'ed your LAN?

I think I had these issues as well when I installed my box, so I used a
local dhcp server to "see" the exchange of the packages. I wrote also a
howto that time:

Just another thought: Which LAN connection are you using. I am unsure if
anything else than "LAN1" will work.

> I tried every available Debian firmware, even the Etch one, which at
> least gives me flashing LEDs, but still no SSH connection. I tried
> static and DHCP network configuration, but it does not seem to get to
> the network initialization.

In earlier kernels, the handling of the LEDs was not supported, so the
orange one remains blinking.
I am not sure if the network configuration used by the original firmware
will be used with the debian installer.. Could be that for a static setup,
it will use (or so... see my howto).

> I used official firmware 2.01.09 and 2.01.10, which run very well, but
> installing Debian does not work. I would like to try an older official
> Thecus firmware, but the oldest one I can find is 2.01.09.
> At least the device itself seems to be ok, as the stock firmwares
> don't give me any errors.

As you are replacing the firmware, it is gone with the flashing of the
installer. Therefore, it is independent of the original version.
With very old firmware you cannot access RedBoot over ethernet, but that
is the only difference I'm aware of.

> Maybe someone has a hint for me, or an older official firmware
> available so I can try it? Did someone experience the same, or similar
> problems?
> Unfortunately I don't have a serial connection, so I cannot give further
> debugging information.

If you got a change to get one of these USB-serial adapters, this will
probably will really help finding the problem. (They are only a few bucks
though and might be handy if at a later time something is wrong -- for
example my box once did an hickup as fsck thought it has found an
corruption due "last mounted in the future" waiting for a desperate "Yes")

> I am deeply grateful for every reply, as I don't have a clue what's
> wrong.
> --
> Greetings, Kai
> "In a world without walls and fences, who needs Windows and Gates?"

> --
> To UNSUBSCRIBE, email to debian-arm-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org

Reply to: