[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Test images for Debian lenny rc2 available

On Sun, Mar 08, 2009 at 07:04:02AM +0000, Bob Cox wrote:
> On Sat, Mar 07, 2009 at 22:32:14 -0800, Marc Singer (elf@buici.com) wrote: 
> > In testing another Debian install on a slug, I found a host that won't
> > set the clock.  During installation, there was a step where it tried
> > to set the clock and the installer asked if I wanted to continue
> > waiting while it tried to set the clock.  Once it rebooted the host,
> > the system hung while attempt to set the clock.
> > 
> > I recall that I disabled the hwclock command when I used this slug.
> > 
> >     ...
> >     [42949407.470000] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
> >     [42949407.470000] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
> >     [42949407.480000] usb usb3: Product: OHCI Host Controller
> >     [42949407.490000] usb usb3: Manufacturer: Linux 2.6.26-1-ixp4xx ohci_hcd
> >     [42949407.490000] usb usb3: SerialNumber: 0000:00:01.1
> >     done.
> >     Setting the system clock.
> > 
> > Eventually it gives up and continues to boot.
> > 
> > Is the cause of this kind of failure known?  Fixable?
> I think I remember this thread or one very similar.  There are
> references to this sort of problem at
> http://www.nslu2-linux.org/wiki/Debian/TroubleShooting with a short term
> fix being disabling the hwclock command at startup and also suggesting
> changing the clock battery.  My fix was to remove the battery, short
> across the battery connections on the board to ensure all capacitors
> were discharged and then replace the battery.  It worked for me.
> However, with hindsight, it might have been more sensible just to
> replace the battery and that probably makes even more sense as slugs are
> getting older.  There must be a limit to how many times the case can be
> opened without breaking something ;-)

I seem to recall this we as well.

The idea that this is a battery failure is suspect as this battery is
still 3V when loaded.  IIRC, I was able to recover the clock
functionality by installing the Linksys FW and the installing Debian
again.  However, that fix wasn't permanent.

hwclock disable it is.


Reply to: