[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: firefox on armel

gdb /usr/lib/iceweasel/firefox-bin

(no debugging symbols found)
[New Thread 1100690560 (LWP 3053)]
[New Thread 1109079168 (LWP 3055)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1090010240 (LWP 3040)]
0x40048800 in ?? () from /usr/lib/iceweasel/libmozjs.so

I also tried
gdb -s /usr/lib/debug/usr/lib/iceweasel/firefox-bin /usr/lib/iceweasel/firefox-bin
The same result:
(no debugging symbols found)

Wouter Verhelst wrote:
> On Tue, Sep 18, 2007 at 02:25:05PM +0400, Sergey Smirnov wrote:
>> Riku Voipio wrote:
>>> On Fri, Sep 14, 2007 at 01:30:33PM +0400, Sergey Smirnov wrote:
>>>> Do anybody have firefox/iceweasel for armel?
>>>> firefox from Debian repository crash on my Zaurus with Debian armel.
>>>> http://www.gtlib.gatech.edu/pub/gnuab/debian/pool-armel/main/i/iceweasel/iceweasel_2.0.0.6-1_armel.deb
>>> Can you debug this crash? install iceweasel-dbg start iceweasel
>>> with gdb. Using a mozilla based browser on armel is certainly possible,
>>> as the maemo people have done. However their code is based on firefox
>>> 3.0 cvs + goatload of patches[1]. It is very much possible that some
>>> important fixes for arm are included there..
>>> [1] https://garage.maemo.org/plugins/scmsvn/viewcvs.php/mozilla/trunk/microb-engine/microb-engine/debian/patches/?root=browser
>> I installed iceweasel-dbg. Problem with binary file:
>> /usr/lib/debug/usr/lib/iceweasel/firefox-bin: cannot execute binary file
>> $ file /usr/lib/debug/usr/lib/iceweasel/firefox-bin
>> /usr/lib/debug/usr/lib/iceweasel/firefox-bin: ELF 32-bit LSB executable, ARM, version 1, dynamically linked (uses shared libs), not stripped
> No, you need to run the regular iceweasel, not the binary in the -dbg
> package. That only contains the debugging symbols of the regular
> binary; gdb is clever enough to pick those up when you run it.
> So just
> gdb /usr/bin/firefox-bin
> will work.

Reply to: