[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch for ARM / Netwinder: where is NPTL support?

On Thu, May 10, 2007 at 06:09:57PM -0700, Sergey Chemishkian wrote:
> 'getconf GNU_LIBPTHREAD_VERSION' on Yesbox (Thecus n2100) running Etch
> release, reports 'linuxthreads-0.10'. So, was Etch for ARM release shipped
> with glibc using old Linux threads, not NPTL? Is there an option to install
> glibc with NPTL from APT repositories?

glibc2.5 with NPTL is available from sid. So in theory you can just
dist-upgrade to sid. However, you need to make sure the kernel and
initramfs flashed to you N2100 are still fully working. If you want
to play safe, you can use debootstrap to create sid chroot.

"rm -rf" only sounds scary if you don't have backups

Reply to: