[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Failure of Debian installer on NSLU2


I've already got an NSLU2 running Unslung which seems to have lots of 
oddities and bugs/"features". I've just acquired a new NSLU2 and was 
pleased to see that the Debian installer supports it pretty 
much "straight out of the box". I've used Debian on PCs for many years so 
this is a great improvement for me over Unslung.

I've been trying to install Debian on the new NSLU2 using the instructions 
at http://www.cyrius.com/debian/nslu2/install.html but it never appears 
on my network! I am using the unofficial image from 
http://www.slug-firmware.net/d-dls.php so that I don't need a USB 
ethernet adapter.

I've tried flashing several times from either the linksys web interface 
(the initial attempt and after reflashing with linksys firmware) or using 
upslug2. The firmware erases and the new one is installed fine followed 
by the reboot. After this, it never beeps at me, the status LED stays 
red, and the ethernet LED is green.

At this point, I'm meant to wait 10-15 minutes until it beeps 3 times and 
I can ssh into the installer. (The installation instructions do not say 
when a disk should be plugged into the device, apart from it should eb 
unplugged when flashing the firmware.)

I set the IP address to something more suitable for my network through the 
linksys web interface (the first thing I did). I cannot ping either this 
IP address or the default When the pings are running (or I 
try nmap) the ethernet LED on the NSLU2 blinks.

Reading through the mailing list archives, others have also had this 
problem. One person could see their NSLU2 using nmap and it had picked up 
an IP address using DHCP: mine is not probing my DHCP server. Running 
nmap on a wide spread of my network doesn't show anything for the new 
NSLU2 (I was cunning enough to get its MAC address before starting on 

Another poster tracked the fault to a corrupt RTC setting. I tried 
removing the battery for a few minutes but I get same result.

I've also flashed it with a SlugOS firmware and that boots fine: the RTC 
was set to something like 1999 so I set it to the current date and 
retried the Debian image. Same result!

I have been doing this all with a 1 GB flash drive (I know that I need to 
manually partition this so I get some swap) but have a proper USB hard 
disk on the way (wouldn't have thought that would change anything).

Has anyone got any suggestions for what to try next, apart from putting a 
serial console on it to see what is happening? I know I can reflash it 
with SlugOS and install Debian from that but I'd much rather do it "the 
proper way" if possible to help test this out.



Reply to: