[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-installer rc1 for NSLU2 available

I'm seeing some weird behaviour with boot-up...

When I hit power the first time (from off), my slug will start making some disk noise like it's loading...  it will do so for about 3 or 4 minutes, disk activity stops...  However the NIC will not start (slug doesn't ping)...   After 10 minutes I go over and hit power again (already on), more disk activity and after another 3 minutes, the slug starts to respond to pings and eventually I can SSH in...

It's rather strange that it is pausing, might have to do with me hard crashing the box while trying to tune channels in MythTV...  not too sure...

On 11/5/06, Andrew M.A. Cater <amacater@galactic.demon.co.uk> wrote:
I got two queries from Martin - one via the list and one to me direct.
Copied to list for info.

On Sun, Nov 05, 2006 at 10:13:44AM +0100, Martin Michlmayr wrote:
> * Andrew M.A. Cater < amacater@galactic.demon.co.uk> [2006-11-04 23:41]:
> > >  - If you want to install Debian on a fresh NSLU2, please follow the
> > >    instructions at http://www.cyrius.com/debian/nslu2/install.html
> > >
> > Didn't work very well initially: had to reflash the Linksys firmware and
> > then use the upgrade from the web panel - this is on a NSLU2 which has
> > been flashed several times, however :)
> Can you describe *what* didn't work well?
> --
Following the instructions from the web page given was fine: obviously,
I knew that I needed the non-free firmware since the ethernet drivers
aren't already installed yet. This is on a second slug, one that now
runs at 266MHz, and was previously running DebianSlug.

Two attempts at pushing the image across using upslug2 both appeared to
work - but in fact left the machine hanging and unresponsive. Nmaps of
the local network showed nothing at all. Reflashing with the original
Linksys firmware (obtained from the Linksys download site) allowed me
to then treat the Slug as brand new. A flash under those circumstances
worked first time. I hadn't set up all the parameters on the Linksys
admin pages so the Slug came up as dhcp obtained from my router as - not on nmap is your friend
if you want to find an errant Slug :)

Thereafter, all worked well. I unchecked the tasksel "install base
system" to save time and wished I hadn't: dselect to install it
afterwards took ages :)

Other than that, it's perfect and the instructions are relatively
foolproof. At this point, you could argue that the need to debootstrap a
Slug has disappeared again.


> Martin Michlmayr
> http://www.cyrius.com/

To UNSUBSCRIBE, email to debian-arm-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

--- == __/ t.O ==--
Reply to: