[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Repost of a Debian Woody/pppoe question from debian-users

I tried for about 2 weeks to get pppoe working under the netwinder and
woody. I tried rp-pppoe, kernel mode pppoe packages, other user mode
packages, and all of them failed. Talking with David Skoll I found out
that rp-pppoe probably would not work on an ARM because of frame packing
issues and other such issues. If you do get it to work, I'd be *very*
interested in how you got it to.

On Fri, 2002-03-01 at 00:38, Rajesh Saxena wrote:
> Please note that I had initially posted this on the debian-user list but it 
> was indicated to me that this question should probably be asked here. Has 
> anyone else had success using pppoe while running debian woody on a 
> netwinder? I'm using the following packages.. ppp_2.4.1.uus-1_arm.deb and 
> pppoe_3.3-1_arm.deb and running the 2.4.16-rmk1 kernel.
> I'm pretty sure it's a problem with my Debian configuration because I
> have no connectivity problems using Windows or a Netwinder(running a
> modified version of redhat). Can someone please take a look at the
> errors / my configuration files and point out what I'm doing wrong?
> My /etc/network/interfaces file says this..
> auto lo
> iface lo inet loopback
> auto eth0
> Does that look right? I had previously compiled and tried the latest 
> rp-pppoe source distribution (before I learned of the debian pppoe 
> package)and I remember reading that no interfaces(attached to the adsl 
> modem) should be brought up at boot time or configured at all. I don't 
> remember reading that in any of the debian's pppoe documentation.. either 
> way, I've tried it both ways and still experience the same problem.
> I've set up pppoe numerous times before on linux and bsd so I know I'm 
> overlooking something really small but I just can't put my finger on it. Any 
> hints or suggestions will be greatly appreciated.
> ---
> Whenever I issue the command 'pon dsl-provider' I get the following
> errors in /var/log/syslog ..
> pppd[431]: pppd 2.4.1 started by root, uid 0
> pppd[431]: Serial connection established.
> pppd[431]: using channel 15
> pppd[431]: Using interface ppp0
> pppd[431]: Connect: ppp0 <--> /dev/pts/0
> pppd[431]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x66929177>
> <pcomp> <accomp>]
> pppd[431]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x66929177>
> <pcomp> <accomp>]
> last message repeated 5 times
> pppd[431]: Terminating on signal 15.
> pppd[431]: sent [LCP TermReq id=0x2 "User request"]
> pppoe[432]: Received signal 15.
> pppd[431]: Script pppoe -I eth0 -T 80 -m 1452 finished (pid 432),
> status = 0x0
> pppd[431]: Modem hangup
> pppd[431]: Connection terminated
> pppd[431]: Exit
> And sometimes it says this (including the errors above)..
> "LCP: timeout sending Config-Requests"
> "Timeout waiting for PADO packets"
> /etc/ppp/peers/dsl-provider is available at:
> http://members.rogers.com/mr.suit/debian/pppoe/dsl-provider
> /etc/ppp/options :
> http://members.rogers.com/mr.suit/debian/pppoe/options
> /etc/ppp/pap-secrets :
> http://members.rogers.com/mr.suit/debian/pppoe/pap-secrets
> _________________________________________________________________
> Send and receive Hotmail on your mobile device: http://mobile.msn.com
> -- 
> To UNSUBSCRIBE, email to debian-arm-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: