[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Netwinder NFS root install


I am new to this list, but have spent some time researching the archives
and haven't seen my specific issue come up.  If this isn't the appropriate
list for this discussion, please feel free to point me in the correct
direction.  I apologize for this being so long, but I wanted to provide
enough information... Also, please forgive my terminology if it's not
correct -- I am not new to Linux, but am still very new to Debian.0

My problem is this: I want to install Debian Linux onto a Netwinder that I
inherited from the company that I work for.  I ran it with the original
Corel/Rebel? RH-like distribution for a while, then finally got fed up
with it not working very well and installed Debian 2.2 on it.

Not long after that, the hard disk went bad, so it got turned off and put
up on a shelf.  I replaced it with a P5-200 system, but that machine
really doesn't have the CPU power that the Netwinder had, so this past
weekend I decided to try to get the Netwinder up and running in an NFS
root environment.  I have an extra 6GB disk in the PC and have it exported
to be the root fs of the Netwinder.  The Netwinder has no hard disk

The closest I've gotten to a successful install was by using the
2.2.25-2001-06-10 disks-arm images.  The tftpboot.img doesn't have modules
for NFS, so I used the linux image and the drivers.tgz to put the nfs
modules onto the tftpboot.img file (lots of mounting loopback and
re-compressing and all that).  Specifically, I put the nfs.o, lockd.o, and
sunrpc.o modules onto the initrd.

That seems to be so very close ... I can switch to the 2nd VT once the
Debian/GNU Installation Menu is running (dbootstrap?), and I can insmod
the modules, but when I run:

mount -t nfs 192.168.x.1:/export/root/netwinder /target

The NFS server logs:

rpc.mountd: authenticated mount request from 192.168.x.5:657 for
/export/root/netwinder (/export/root/netwinder)

But the Netwinder shell says:

Mounting 192.168.x.1:/export/root/netwinder on /target failed: Invalid

(I tried also using '-o nolock' but the results are the same.)

mount, in this case, is busybox v0.43, which seems kinda old.  I thought
that might be the problem, but I have no (easy) way to get a new one
compiled for the Netwinder, that I know of.

I have played around with the woody disks, but don't really know enough
about why that didn't work.  The kernel seemed to load, but then said it
couldn't mount root fs on 01:00, so I kind of gave up on it.

I also tried the boot disks on ftp.armlinux.org, but that didn't have NFS
in it, either, and I was either unable to break apart the kernel and
filesystem or the filesystem is not a gzipped ext2 filesystem.  In either
case, I couldn't add the nfs modules to the boot image because I couldn't
mount the filesystem on my PC.  :-(

So... anyone have any suggestions?  Is this just not a good idea?  I've
seen some oblique references to NFS root Netwinders, but nothing specific
and nothing recent.

Thanks in advance,

Reply to: