[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: X on armLinux.

On Sun, Oct 07, 2001 at 11:34:35AM +0100, Anand, coggi.net wrote:
> Hi Russell,
> I still get te same error when I do
> fbset -accel 0
> then startx
> AM I missing some vital command?

I think he's hit the core XFree86 design bug (not some ARM Debian specific
thing, although it seems to be be only hardware that happens to be ARM based
that is using fbdev enough for it to hit)) whereby someone foolishly wrote
the fbdev driver to attempt to swap the frame buffer's bits per pixel
without changing the resolution.

Clearly this doesn't work when you were at 4bpp and had a high enough
resolution to use all the VRAM, and fbdev driver has now swapped you to 8bpp
and then attempts to write direct to the VRAM **assuming the same

However, I'd agree that Debian is failing. It's failing to provide 
workable default setup (eg an XF86Config file) that works round this problem.

[In that I can't see how to fix fbdev without breaking a promise to someone.
I believe that the "default" mode de-facto does promise that it will change the
bpp without changing the resolution. Which is an imbecilic promise]

Followups to debian-arm about sorting this mess out, I suggest.
Don't cross post to both lists.

Nicholas Clark

Reply to: