[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What's the status on Xfree86 4.1.0?

Okay, I've tried to build X twice now, both times with the same error. I've put the log at http://lyre.mit.edu/~powell/debs/xfree86_4.1.0-2.log but it ends with:

rm -f encodings.dir fonts.dir
+ LD_LIBRARY_PATH=../../exports/lib
+ ../../exports/bin/mkfontdir -r -p /usr/X11R6/lib/X11/fonts/encodings/ -e . -e large . ../../exports/bin/mkfontdir: error while loading shared libraries: libfakeroot.so.0: cannot open shared object file: No such file or directory
make[4]: *** [encodings.dir] Error 127
make[4]: Leaving directory `/home/hazelsct2/xfree86-4.1.0/build-tree/xc/fonts/encodings'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/home/hazelsct2/xfree86-4.1.0/build-tree/xc/fonts'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/home/hazelsct2/xfree86-4.1.0/build-tree/xc'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/home/hazelsct2/xfree86-4.1.0/build-tree/xc'
make: *** [debian/stampdir/install] Error 2

Of course, libfakeroot.so.0 is in /usr/lib/libfakeroot/ but that should not be a problem, right? Any ideas?

D'oh! I was trying to build under 2.2.19, which is known to cause problems with fakeroot. I'll reboot to 2.4.5-netwinder and try again.


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: