[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Assabet

On Sun 25 Mar, Harishankkar wrote:
> Hi all,
> we have downloaded the linux kernel to the assabet .We have
> followed the instructions in the web site
> http://www.cs.cmu.edu/~wearable/software/assabet.html.

I have written an updated version of this doc, (which makes up the 'Assabet'
chapter of my book, see website below) which may help, although you seem to
be doing approx. the right things.

> .We got the linux penguin image on the LCD since we have included the frame
> buffer support in the kernel.

OK, that generally means it is working.

> After this we get the D8 LED constantly blinking.What does this mean?
> Does this mean that we have loaded linux properly.

That happens after the kernel has uploaded and booted successfully. Before
upload - it should always be on - LED D9 (orange) should blink 4 times then
stay off after a reset. So it sounds to me like this is all fine.

If your LEDs don't do the right thing, it may be that your flashed copy of
Angelboot is corrupt and using JFlash-linux again (and re-uploading the
kernel+RAMdisk) is in order.

> Now then we tried the
> RAM disk image that is given in the site. After downloading the kernel only
> the TUX image in the LCD screen appears minicom gets started up and no
> messages on the serial port,what could be the problem?. We have configured
> minicom for 9600 8 bits 1 stop bit.

That's correct - note that it should be 'no hardware handshaking' too.

> Is it possible to get a login prompt in the serial Port?

yes. This is a kernel config option: CONFIG_SERIAL_CONSOLE - did you set
that when you compiled your kernel (or are you using a pre-compiled one)?

> We are using the
> angelboot utility for linux as the host program fro downloading. When we
> tried to make a RAMDISK on our own we got a message in the serial port

> Mount root file system(ext2)64 K freed
> Kernel Panic:init not found
> It did not say anything on RAM DISK initialised.

> what could be the problem?

hmm, if you are getting some message then your serial connection is OK - it
looks likes the console messages are going somewhere else (probably due to
the above config option).

> Is it possible to single step the code ?I am having only the assabet only .

not really. BTW you are probably better off asking these questions on the
linux-arm mailing list as they are not debian-specific.

Aleph One Ltd, Bottisham, CAMBRIDGE, CB5 9BA, UK  Tel (00 44) 1223 811679
work: http://www.aleph1.co.uk/     play: http://www.chaos.org.uk/~wookey/

Reply to: