[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Memory, IDE performance, idle speculation, THANKS!

Brace for long message...

Philip Blundell wrote:

> >Funny thing is, I compiled 2.3.35-rmk1 with
> >CONFIG_CMDLINE="mem=128M root=/dev/hda3 ide0=autotune ide1=autotune"
> >so it should see all 128M, right?
> Try passing that command line from NeTTrom instead.  I'm not sure the
> Netwinder kernel takes any notice of CONFIG_CMDLINE.

Hmm, thought of that, but couldn't find any appropriate NeTTrom environment
variables... Oh, there's cmdappend.  Duh!  With "setenv cmdappend mem=128M" it
doesn't boot!!  Now when I try to power down and back up, NeTTrom doesn't
start!!!  It calculates the bogoMIPS, then says:

Memory: 124176k/126976k available (796k kernel code, 52k reserved, 1952k data)
Problem: block on freelist at 00000000 isn't free.
Kernel panic: task[0] trying to sleep
In swapper task - not syncing

Okay, glad I waited a few minutes before sending this message.  I unplugged
again, waited about ten minutes, and now NeTTrom is saying:

Memory: 11064k/12288k available (796k kernel code, 52k reserved, 376k data)

and then goes on its way.  Funky!  Tried mem=128M again just for fun, no boot.
And once again, NeTTrom kernel panics if I unplug and replug less than a couple
of minutes later.  I think I been gipped...

So what's that NeTTrom business all about?  Does my cmdappend make NeTTrom think
it has has 128M when it really has 64?  But I didn't even save-all the
parameters, so it shouldn't know anything about that cmdappend change, right?

And one other question: how do I pass two kernel args on the command line?  I
tried using single quotes and double quotes, and also using backslash-space
between the parameters, but it always only picked up the first argument, doing
things like "cmdappend    'mem=128M     none" (from printenv) when I tried to
wrap all the args in single quotes...

> >Second, using hdparm -t /dev/hda in RedHat gives 4.07 MB/sec, in Debian
> >2.2.13 1.59 MB/sec (!), in Debian 2.3.35-rmk1 2.63 MB/sec.  Is this
> >real?  Any ideas on how we might get Debian kernel 2.2/2.3 up to the
> >RedHat kernel 2.0 level of IDE performance?
> See above. :-)
> Also you could try playing with hdparm to make sure that DMA, readahead,
> 32-bit transfers, &c. are enabled.

Cool.  ide0=autotune in cmdappend does nothing.  However, hdparm -c1d1 /dev/hda
picks it up to 6.23 MB/sec!  Readahead was already set.  Thanks, my disk is
suddenly >130% faster!

Funny- in RedHat, hdpart -c1d1 brings it from 4.07 to 6.20 MB/sec (neither was
set before).  There must have been something else going on there in the first

Jim Studt wrote:

> The 200MHz SA110 (like netwinder) burn about 1 watt.  Way back in May
> 1999 Intel issued a press release mapping out the next generation
> StrongARM at 600MHz and < 0.5watts.  Sampling first half 2000.  Looks
> like StrongARM is about half the cost of Crusoe.

Excellent.  Forgot about that.

> I suspect there is room for Crusoe and ARM.  You sure wouldn't want to
> run an IA32 emulator on ARM, but if you are running native the choice
> will depend on cost, power dissipation, and performance.

Thanks very much, this makes sense.  Competition is our friend. :-)

          Adam Powell                     http://lyre.mit.edu/~powell/
          Thomas B. King Assistant Professor of Materials Engineering
          77 Massachusetts Ave. Rm. 4-117         Phone (617) 452-2086
          Cambridge, MA 02139 USA                   Fax (617) 253-5418

Reply to: