[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

It boots!

Howdy all,

No more chroot for me, I figured out how to get Debian to boot.  :-)

First off, I got San's new Nettrom and installed it.  Instructions on
how to do this are on his web page.  It's really slick - I had no
problems getting it to boot of an alternate partition.

Some of the base packages need to be fixed/built:

  util-linux, mingetty  - needs the patch David Welton talked about
  shadow                - needs a small patch to configure.in so it reacts
                          properly with utmpx.h

I'll make some uploads tomorrow.

It took me a while to figure out a bunch of oops' that I was getting
from init.  It turned out that pretty well all apps try to do a little
bit of floating point in their initialization.  I fixed it by adding:

  insmod -f /lib/modules/misc/fpem.o license=0

at the beginning of /etc/init.d/rcS .

Unfortunately, our bash also has the floating point code in it, so it
won't work (you need bash to call the script to insert the emulator
module).  I had to install Corel's bash, /lib/ld.so, and
/lib/libc.so.4* into the Debian partition.  We'll have to figure out
how to get around this...

I was really happy to see xdm pop up, and I could log right in.  My
backspace key even worked!  However, the arrow keys still don't work.
Maybe when we get kbd/console-tools going, that will resolve itself.

I'm really liking my machine now.  Being able to boot directly into
Debian makes all the difference in the world - you know, it's like
that warm, fuzzy feeling you get when you come home after a long trip.


 - Jim

Reply to: