[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: After a few weeks of almost no issues, Wheezy doesn't boot anymore

Thanks a lot for your helpful responses guys. I'm at a public computer
right now and haven't had a chance to try your ideas yet, but I've
noticed a few things that I'd like to clarify:

On 5/9/13, Chris Swenson <chris@cswenson.com> wrote:
> Given that these problems were occurring before, I'm guessing you have bad
> hardware that just decided to coincidentally die with your new install of
> the OS. Perhaps all the writes to the disk did it when you upgraded.

I installed Wheezy from the get-go on this machine; I had done a few
apt-get upgrades but no major distribution upgrades. Oddly enough, the
hardware didn't seem to die in conjunction with anything important;
just a reboot.

On 5/10/13, "Артём Н." <artiom14@yandex.ru> wrote:
> 10.05.2013 05:04, Harry Prevor пишет:
>> The normal images didn't work
>> for some reason now forgotten, so I had to use the unofficial
>> installation images that included nonfree drivers.
> What are the drivers?

I've forgotten by now, but all I remember is that the official USB
installation images didn't work because they thought my USB was a CD
drive or something along those lines, and then tried to look for CD
drives and failed (because I have none on this machine). I asked
#debian about it and they said to try the unofficial images, so I did
and they worked fine.

> How did you install the system? From DVD or from network? Or in some other
> way?

I installed it via the unofficial USB installation images with
included proprietary drivers.

>> - Two HDDs connected and set via /etc/fstab to mount on boot (this
>> configuration worked in previous boots so I doubt that is the issue)
> SSD?

No; they are HDDs unfortunately.

On 5/10/13, ville@tiensuu.eu <ville@tiensuu.eu> wrote:
> Have you installed/upgraded any drivers or installed a new kernel just
> before you rebooted the system and it started to crash on boot like this?
> Nvidia's proprietary drivers have always been a pain.

No, or at least, not that I know of. I might have done an apt-get
upgrade or something, but nothing major. I had already booted
successfully directly after installing the nvidia driver before.

On 5/10/13, Darac Marjal <mailinglist@darac.org.uk> wrote:
> If the only proprietary driver you need is the Nvidia X driver, then a
> rescue disc will work fine for you. You're likely to be pottering about
> at the command line anyway.

I don't *need* the nvidia driver at all; everything works in the
installation without the drivers AFAIK -- But because my brother uses
this machine for gaming he needs the better 3D performance, so I
installed it after installing the system. I had to use the
installation image with drivers for other reasons -- See above.

When I get home, here is a list of the things I'll try, in order:

- Make sure the RAM is securely in place
- Try to boot into single-user mode via GRUB; if that doesn't work,
I'll try going in via a LiveUSB and chroot into the system
- Pastebin /var/log/messages and /var/log/syslog
- Pastebin partition / filesystem information
- Pastebin /etc/fstab plus result of sfdisk -lxuM /dev/sd
- Pastebin debsums -c
- Run fsck on my hard drives
- Include SMART logs (will look that up later)
- Install and try out the memory checking package

If any of this is wrong, please let me know. Thanks again.

Harry Prevor

Reply to: