[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cryptroot Volume group not found

Thanks for the swift reply. Well. The second time I tried it I
switched to a terminal to verify that it was inputting the correct
characters during the install, which it did. I have no odd settings in
BIOS as far as I can tell and I'm not using Extended ASCII. The
bootloader (grub) doesn't get my keyboard layout (swedish) and I'm
stuck with US layout but that shouldn't be a problem afaik. Whether
the actual decryption prompt gets the correct characters there's no
way to tell; at least none I know of. From what I understand the
problem seems to be the same, or at least similar, to the one in the
bug report in my first message, i.e. it cannot verify my password as
it's not trying to open the correct volume. The only thing about this
that confounds me is that that bug was fixed two years ago. With that
bug you didn't get to the passphrase stage, though.

I'm trying out an old Lenny CD to see if that works. If it doesn't,
I'll try again with Squeeze and input my password with the assumption
that I'm using a US keyboard as that is the only option I haven't

Thanks again!

On 4/6/12, Chris S. <cs.swenson@gmail.com> wrote:
> Hash: SHA1
> Audrey:
> I'm not sure this is the best place, either. But here are some ideas:
> One piece of advice that I read about encryption is to ensure your
> keyboard it outputting the keys you expect. That could cause the
> password to not work if there was something like CapsLock on, or if you
> have a smaller keyboard that has an overlaid number paid and NumLock was
> on. Do you have any idea if that could have happened?
> Do you have any complex characters in your password, such as high ASCII
> characters? Not sure if this matters, but does the boot loader
> understand the input of these characters...?
> Are there any unexpected settings enabled/disabled by your BIOS? Like
> NumLock?
> - -- Chris
> On 04/06/2012 05:21 AM, Audrey Pauley wrote:
>> Hi!
>> I don't know whether this is the place for this but I'll try anyway.
>> I'm trying to install Debian on an AMD64 system with encrypted root.
>> When rebooting after install I get the following:
>> Loading, please wait...
>> Volume group "system" not found
>> Skipping volume group system
>> Unable to find LVM volume system/root
>> Volume group "system" not found
>> Skipping volume group system
>> Unable to find LVM volume system/swap_1
>> Unlocking the disk /dev/disk/by-uuid/blah-blah-blah (sda5_crypt)
>> Enter passphrase:
>> And the passphrase I've chosen doesn't work. Sorry for the messily
>> written output but I had to write it down by hand, as it were. I've
>> tried using both the first stable CD and the latest weekly build of
>> testing but I get exactly the same result. I've also tried messing
>> about with AHCI/IDE settings for my SATA controllers in BIOS to no
>> avail. Searching for help I found this
>> (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=554506) from two
>> years ago and some other things that are very similar but marked as
>> fixed.
>> I'm not on the list so please CC me.
>> Any help would be greatly appreciated. Thanks!
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> iEYEARECAAYFAk9+4vgACgkQIZkx3dzEh22ZSwCgnf47EwyyH2QQOv/Kaqd5BBOl
> hzwAnjdM4bROm1P1semNUdehmbAI9nQm
> =l2Rr

Reply to: