[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: flash for etch amd64?

Am Dienstag 03 Juli 2007 schrieb Douglas Allan Tutty:
> I'm running Etch on amd64 on my Athlon64.  I use Konqueror.
> I have the libflash-mozplugin installed but flash sites (and adobe's
> test site) don't work.
> After I came back from holidays, I reactivated my subscription to the
> debian lists and saw a reference to something like "now that flash works
> for amd64" but there was no link, footnote, whatever.  I tried to google
> for 'flash solved site:lists.debian.org' but didn't get anything
> current.
> I don't want to go the route of a 32-bit chroot just for flash.
> If there really is a way to view flash sites in amd64 without a chroot,
> could someone reply with a link and change the subject to include
> [solved] ?
> Thanks,
> Doug.

Hi Doug,

you can try the packages "gnash" or "klash". Sometimes flash will work with 
them. I had success with mozilla firefox on flash-sites, but there is no 
guarantee, it will always work. Klash made problems, too, on some websites, 
especially www.heise.de. There sometimes is opening a window with a 
comment "fscommand not recognized", whatever this might mean. With konqueror 
and klash installed (klash is for KDE), the cpu`s work increases to 100 

Flash in mozilla and in konqueror seem to work different. 

I had success with an installed 32-bit opera. It seems, opera is using its own 
flash, and , as it is 32-bit and is working together with the libs out of the 
chroot, is is working fine. 

Oh, I forgot to explain: All programs I use, are not running in the chroot. I 
have a sid-chroot installed (minimalistic), and the paths are 
in /ld.so.cache. So every application is using the correct libs, whatever it 
needs. So: The chroot is only for holding the needed 32-bit-libs.

Hint: keep the chroot as minimalistic as possible, as some libs could 
interfere with the 64-bit-libs, i.e. the nvidia-glx-32 of the 64-bit-systems 
is interfering with the nvidia-glx in the chroot. 

I might be possible, to install the flash-packages in the chroot, but this is 
not tested by me, just an idea. 

O.k., I hope, this will help a little bit.

Best regards and good luck


Reply to: