[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems upgrading libc6

Am Dienstag, 10. April 2007 02:23 schrieb Andrew J. Barr:
> Luis Hidalgo wrote:
> > Hi,
> >
> > I think I have a serious problem. I tried to upgrade my packages using
> > apt-get upgrade but instead of being successful
> > the following message appeared:
> >
> > dpkg: error processing
> > /var/cache/apt/archives/libc6_2.3.2.ds1-22sarge6_amd64.deb (--unpack):
> >  trying to overwrite `/usr/lib64', which is also in package
> > nspluginwrapper Errors were encountered while processing:
> >  /var/cache/apt/archives/libc6_2.3.2.ds1-22sarge6_amd64.deb
> > E: Sub-process /usr/bin/dpkg returned an error code (1)
> I would temporarily remove nspluginwrapper and upgrade your libc6. Then
> check if there is a new version of nspluginwrapper available, and if
> not, or you still have this problem after upgrading that package, file a
> bug.
> HTH,
> Andrew

This problem happened in the past already. My solution was (but please check, 
what you are doing), to get into /var/cache/apt/archives and install the libc 
manually with the --force-all option.  


dpkg --force-all -i libcxxxxxx.deb

But you should know, what you are doing !

Best regards


Reply to: