[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: chroot: firefox browser plugins

Jaime Ochoa Malagón schrieb:
On 12/21/06, Les Gray <lgray@bigpond.net.au> wrote:
Jaime Ochoa Malagón schrieb
I had have a similar problem with directories in rbind inside a chroot
> al the files are in the same partition?
when firefox is installed to /usr/local in chroot, yes. when it's
installed in /home/<user>, no. But I have no problem linking to other
files in the chroot from this home directory, even though it's on
another partition...
> do your use the tab key to make de link?
no, just the terminal and eg. /usr/local/firefox/plugins# ln -s
<path_to_javaplugin> .

if you want to "check" the path you could use the tab key while you
are typing to "complete" the text...

are you using the absolute path?
Oh, I forgot about the tab key for this :) But I have all the plugin paths updated and saved in my 'setup notes', and I just use the X keyboard to (carefully) paste them into the terminal. and, yes, they are the absolute paths.

Doesn't the tab key achieve the same result?
> as a las resource why do you not copy the files of the plugins to your
> directory?
I tried that. The files copy OK but the getfirefox.com Firefox says it
can't find them. It's strange, the Debian firefox obviously makes the
necessary plugin links during the install process, but I can't do so

thats really weird or the plugins are of another arch... 32/64?
I checked that. They are all from things either installed via apt-get in my etch-ia32 chroot, or that I made sure were 32-bit versions when I downloaded them. I also made sure that my copy of Firefox was 32-bit by checking the browser header (I don't think you can download a specifically 64-bit version of Firefox from getfirefox.com, anyway).

Any other ideas? It's certainly got me stumped...


> Best whishes
and to you! :)
> On 12/21/06, Les Gray <lgray@bigpond.net.au> wrote:
>> Hi,
>> I just built myself a 64-bit AMD X2 desktop system and decided I'd give
>> a 64-bit distro a shot. On my recently ebayed last system I was using
>> 32-bit Sarge for just over a year and loved it. I am now happily running
>> Etch RC1 64-bit.
>> Happily? Well, almost....
>> For the relatively few 32-bit programs I need/want to run, I opted for >> the chroot method (as described in the Debian AMD64 HOWTO). I installed
>> Firefox by unpacking the archive from getfirefox.com into
>> /usr/local in my chroot (I prefer not to use Debian-packaged firefox
>> because I've found it to be more crash prone). The browser starts up
>> without a hitch.
>> But, for the life of me, I am unable to create any symlinks in
>> /usr/local/firefox/plugins to the currently installed plugins in the
>> chroot (acrobat and java, atm). Each time I try, it results in a
>> dangling symlink (and, yes, I am issuing each command from within the
>> chroot).
>> I thought it might be a permissions issue (even though I didn't change
>> any), so I tried unpacking firefox in bind-mounted /home/<user>. No
>> change.
>> I also tried 3 methods of installing Sun Java - from the Debian repo,
>> from sun.com, and building locally using java-package. Again, no ability
>> to symlink to the java plugin.
>> I don't get it. I can create symlinks to any other files/dirs in the
>> chroot, just not browser plugins?? I have read permissions on all
>> elements of the plugin path, and write permissions to where I want to
>> create the symlink. I've also tried copying the plugins to the firefox
>> plugins directory, but firefox still doesn't register them.
>> Curiously (or not?), I don't have this problem if I use the firefox
>> version from Debian. It's just 'getfirefox'. I don't want to use the
>> Debian version, though, or another browser. I may use Iceweasel from
>> unstable as a last resort, but I really shouldn't be having this problem
>> in the first place.
>> Any clues? It's the first time I've used chroot, so if I am overlooking
>> something simple, my apologies :)
>> Thanks,
>> Les
>> --
>> To UNSUBSCRIBE, email to debian-amd64-REQUEST@lists.debian.org
>> with a subject of "unsubscribe". Trouble? Contact
>> listmaster@lists.debian.org

Reply to: