[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

chroot: firefox browser plugins


I just built myself a 64-bit AMD X2 desktop system and decided I'd give a 64-bit distro a shot. On my recently ebayed last system I was using 32-bit Sarge for just over a year and loved it. I am now happily running Etch RC1 64-bit.

Happily? Well, almost....

For the relatively few 32-bit programs I need/want to run, I opted for the chroot method (as described in the Debian AMD64 HOWTO). I installed Firefox by unpacking the archive from getfirefox.com into /usr/local in my chroot (I prefer not to use Debian-packaged firefox because I've found it to be more crash prone). The browser starts up without a hitch.

But, for the life of me, I am unable to create any symlinks in /usr/local/firefox/plugins to the currently installed plugins in the chroot (acrobat and java, atm). Each time I try, it results in a dangling symlink (and, yes, I am issuing each command from within the chroot).

I thought it might be a permissions issue (even though I didn't change any), so I tried unpacking firefox in bind-mounted /home/<user>. No change.

I also tried 3 methods of installing Sun Java - from the Debian repo, from sun.com, and building locally using java-package. Again, no ability to symlink to the java plugin.

I don't get it. I can create symlinks to any other files/dirs in the chroot, just not browser plugins?? I have read permissions on all elements of the plugin path, and write permissions to where I want to create the symlink. I've also tried copying the plugins to the firefox plugins directory, but firefox still doesn't register them.

Curiously (or not?), I don't have this problem if I use the firefox version from Debian. It's just 'getfirefox'. I don't want to use the Debian version, though, or another browser. I may use Iceweasel from unstable as a last resort, but I really shouldn't be having this problem in the first place.

Any clues? It's the first time I've used chroot, so if I am overlooking something simple, my apologies :)


Reply to: