[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Is anyone else seeing segfaut on mutt (sid)? - SOLVED

On (10/09/06 23:00), Clive Menzies wrote:
> Moving my .muttrc allows mutt to start (looking to create a local mail 
> folder).  If I then try to connect to the IMAP server (by changing 
> folders), it segfaults having contacted the server.
> So I'm guessing that the fairly dramatic upgrade this morning has 
> changed something somewhere (not mutt) to cause the problem.
> Following the instructions during upgrade, I ran the recommended script:
> sysvinit (2.86.ds1-18) unstable; urgency=low
>  In version 2.86.ds1-16 of the sysv-rc package released 2006-09-06,
>  the update-rc.d script was broken.  When used to to update symlinks
>  it would remove all symlinks for a init.d script if such symlinks
>  existed, and add them if they were missing.  This broke all packages
>  being upgraded after the new version was installed, as their init.d
>  scripts will no longer be executed.  This problem was fixed in
>  version 2.86.ds1-18, but the broken packages will stay broken until
>  their postinst scripts are executed again.
>  Those with packages being broken from this bug can fix it by using
>  'apt-get --reinstall install package' on the affected packages.  A
>  quick way out is to reinstall all the packages with scripts in
>  /etc/init.d/.
>    for p in `dpkg -S /etc/init.d/*|cut -d: -f1|sort -u`; do
>      apt-get --reinstall install -y $p
>    done
> I suspect this is related in some way.

Today's upgrade has resolved the segfault problem... Thanks :)



www.clivemenzies.co.uk ...
...strategies for business

Reply to: