[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Is anyone else seeing segfaut on mutt (sid)?



Manolo Díaz wrote:
Clive Menzies wrote:
Hi

Since the latest round of upgrades mutt won't start; it segfaults when
trying to connect to the IMAP server.  I couldn't see anything similar
in the BTS and so tried to run reportbug but get:
 File "/usr/bin/reportbug", line 485
   if email_addy != def_email:
    ^
SyntaxError: invalid syntax

So I can't even report it.

No, I'm using mutt 1.5.13-1 and it doesn't segfault. In the other hand I, think
that reportbug doesn't need mutt for a bug report.
Moving my .muttrc allows mutt to start (looking to create a local mail folder). If I then try to connect to the IMAP server (by changing folders), it segfaults having contacted the server.

So I'm guessing that the fairly dramatic upgrade this morning has changed something somewhere (not mutt) to cause the problem.

Following the instructions during upgrade, I ran the recommended script:
sysvinit (2.86.ds1-18) unstable; urgency=low

 In version 2.86.ds1-16 of the sysv-rc package released 2006-09-06,
 the update-rc.d script was broken.  When used to to update symlinks
 it would remove all symlinks for a init.d script if such symlinks
 existed, and add them if they were missing.  This broke all packages
 being upgraded after the new version was installed, as their init.d
 scripts will no longer be executed.  This problem was fixed in
 version 2.86.ds1-18, but the broken packages will stay broken until
 their postinst scripts are executed again.

 Those with packages being broken from this bug can fix it by using
 'apt-get --reinstall install package' on the affected packages.  A
 quick way out is to reinstall all the packages with scripts in
 /etc/init.d/.

   for p in `dpkg -S /etc/init.d/*|cut -d: -f1|sort -u`; do
     apt-get --reinstall install -y $p
   done

I suspect this is related in some way.

The point about reportbug is not that it is related to the problem but that I can't report it :)

Thanks

Clive



Reply to: