[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New



On Wednesday 16 August 2006 14:20, Kv237 wrote:
> Hello,
>
> I have about 18 years of experience as a Linux and Unix user and system
> administrator, but after an attempted upgrade about five weeks ago with
> Ubuntu to their Dapper Drake version i ran into serious problems and the
> installation essentially crashed.
>
> I have therefore decided to return to the Debian distribution, since this
> distribution is very stable in my experience. I have decided to try out the
> AMD64 distribution of Sarge, despite the fact that this version is only in
> testing at the moment. The installation image work a lot better than any
> other Debian or Ubuntu installation I have tried out on my computer.
>
> My problem is that the network drivers don't support my ethernet hardware.
> My moterboard is an ASUS K8N4-E Deluxe. The eterhet adapters I have
> attempted to use is a Marwell 88E81111 Gigabit Lan PHY included on the
> motherboard, and a D-link DFE-530TX.
>
> I have attempted to use the forcedeth driver explicitly, but the version
> delivered with the ISO don't recognize my hardware.
>
> I have tryed to use the Linux drivers delivered with the DFE-530TX, but
> they are delivered as source code and the ISO don't contain the development
> environment. I have attempted to install the drivers from a CD with apt,
> but the ISO image don't have apt.
>
> I have attempted to install the drivers for the Maxell HW with dpkg, but
> the ISO don,t have dpkg either.
>
> I attempted to install dpkg into ram memory with the start a shell option
> in the install image, but dpkg is as far as I could find out only available
> as a .deb file which requires dpkg in order to install.
>
> I attempted to find an old ethernet adapter today, in order to install the
> AMD64 port of Sarge. But the only card I could find was a Zonet ZEN3200
> adapter. This adapter requires the driver rt18139.o, and that was not
> available in the ../kernel/drivers/net directory. And before you ask, I did
> look for a .ko extension as well.
>
> Currently I have no idea about how I could install Debian AMD64 without
> help with the drivers and with the current kernel image, i.e. Linux
> 2.6.8-11-amd64-generic.
>
> Could somebody help me by creating a new install image, with the kernel
> replaced with the latest stable kernel and the latest forcedeth drivers
> replacing the versions in the current image. I will be happy to try it out,
> and will of cause report any problems to this mail list.
>
> I will scan this mail list for answers. Thank you in advance for any help
> provided.
>
> With my best regards,
>
> Sören Jonsson, Sweden
> MSc in Computer Science

That DFE card should be using the via-rhine driver which is definitely 
available in the 2.6.8 install kernel or you can try 
http://kmuto.jp/debian/d-i/ for a backported install image for amd64 with a 
2.6.16 kernel to try and use the onboard card.

Stephen

-- 
GPG Pubic Key: http://users.eastlink.ca/~stephencormier/publickey.asc

Attachment: pgpKeT308mKsT.pgp
Description: PGP signature


Reply to: