[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get the right source

On Thu, 2006-08-10 at 11:58 -0400, Lennart Sorensen wrote:
> On Thu, Aug 10, 2006 at 11:02:41AM -0400, Bill Ranck wrote:
> >    I am still trying to get a 64bit smp kernel working on my Dell
> > system.  I have installed and successfully run 2.6.12-1-amd64-generic.
> >    Any pointers or help will be greatly appreciated.  I tried all of the
> > stuff people suggested the last time, at least to the best of my
> > understanding of them.
> The closest I can find is the linux-image-2.6.12 source package on
> snapshots.debian.org.
> http://snapshot.debian.net/archive/2005/09/28/debian/pool/main/l/linux-2.6/
> Latest version in there is 2.6.12-10, for which you can find the
> .orig.tar.gz, the diff.gz and the dsc.  That should be able to be
> compiled given a proper .config file.

Thanks for the help so far.  I have gotten the source files and used the
current config as a starting point (it was in /boot as expected).  I
have compiled the kernel several times, all to no avail.  The system
fails on bootup with something that looks like I need to do *something*
with mkinitrd, but I'm unsure of what.

The last few messages before kernel panic are:

RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4660KiB [1 disk] in ram disk done
UDF-fs: No partition found(1)
kernel panic - not syncing: UFS: Unable to mount root fs on unknown-
block (0,0)

The above is transcribed by hand, so there may be a typo or two.  I
tried using the old initrd, and I tried running mkinitrd (though I think
I'm missing some key factor there) but consistently get these messages
until I go back to the old kernel. 

I feel like I'm making progress, but missing something minor.
Anyone have any pointers?  Even pointers to a more appropriate forum ;-)

Bill Ranck
Blacksburg, Va.

Reply to: