[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please confirm the bug in the soqt package: add on SOLVED



Hi,

well after some people told me that there's no problem at all and the package 
could be compiled I have decided to revised my configuration. And,

after revision the moc version, the g++ version, etc the package version, etc. 
I finally decided to do a:
apt-get install --reinstall  apt-build build-essential g++ g++-4.1 
libstdc++6-4.1-dev   

and magically, the problem disappears ... this is a very disgusting thing of 
the computers!!!!!!

Regards,

Leo


A Dilluns 19 Juny 2006 23:17, Leopold Palomo Avellaneda va escriure:
> It fails with g++-4.1, not with 4.0
>
> Leo
>
> A Dilluns 19 Juny 2006 20:59, Leopold Palomo Avellaneda va escriure:
> > Hi,
> >
> > I think that I have discovered some bug in the libsoqt package. Howeber,
> > please I would like to that some one confirm it before to post a bug.
> >
> > First of all, I cannot compile the package (apt-get source libsoqt20...
> > fakeroot debian/rules binary)
> >
> > Although the error seems about link with qt:
> >
> > checking for Qt library devkit...  -L/usr/share/qt3/lib UNRESOLVED
> >
> > Could not find any way to build against the Qt library. If you
> > are sure Qt is properly installed on your system, see the file
> > config.log to find out what went wrong.
> >
> >
> > if you look on the config.log you will see:
> > configure:29230: g++ -o
> > conftest -g -O2 -I/usr/share/qt3/include    
> > -I/usr/include/Inventor/annex -D_REENTRANT   -L/usr/lib      -L/usr/
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h: In function '_ForwardIterator std::uninitiali
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:110: error: expected nested-name-specifier bef
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:110: error: expected initializer before 'G'
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:111: error: '_ValueType' was not declared in t
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:111: error: template argument 1 is invalid
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:111: error: invalid type in declaration before
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h: In function 'void std::uninitialized_fill(_Fo
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:172: error: expected nested-name-specifier bef
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:172: error: expected initializer before 'G'
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:173: error: '_ValueType' was not declared in t
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:173: error: template argument 1 is invalid
> > /usr/lib/gcc/x86_64-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/st
> >l_ uninitialized.h:173: error: invalid type in declaration before
> >
> >
> > So, I don't know how could be have done the package...
> >
> > If you install the binary, libsoqt-dev you could test this error with the
> > example attached, a simple viewer than could be compile with:
> > soqt-config --build viewer viewer.cpp
> >
> > If it compiles (I doubt) you could see any inventor or vrml file with:
> > ./viewer file.iv
> >
> > I have a sid system upgraded today. My significant debs are:
> > leo@indiana:~/tmp/soqt-1.3.0$ dpkg -l | grep qt
> > ii  gtk-engines-qtpixmap              0.28-1.1                    
> > QtPixmap GTK1.x theming engine
> > ii  gtk2-engines-gtk-qt               0.60-2.1                     theme
> > engine using Qt for GTK+ 2.x
> > ii  gtk2-engines-qtpixmap             0.28-1.1                    
> > QtPixmap GTK2.x theming engine
> > ii  libavahi-qt3-1                    0.6.10-1                     Avahi
> > QT3 integration library
> > ii  libavahi-qt3-dev                  0.6.10-1
> > Development headers for the Avahi QT3 integr
> > ii  libdbus-qt-1-1c2                  0.61-6                       simple
> > interprocess messaging system (Qt-bas
> > ii  libpoppler0c2-qt                  0.4.5-4                      PDF
> > rendering library (Qt-based shared libra
> > ii  libqt-perl                        3.008-1.4                    Perl
> > bindings for the Qt library
> > ii  libqt3-compat-headers             3.3.6-2                      Qt 1.x
> > and 2.x compatibility includes
> > ii  libqt3-headers                    3.3.6-2                      Qt3
> > header files
> > ii  libqt3-mt                         3.3.6-2                      Qt GUI
> > Library (Threaded runtime version), V
> > ii  libqt3-mt-dev                     3.3.6-2                      Qt
> > development files (Threaded)
> > ii  libqt3-mt-psql                    3.3.6-2
> > PostgreSQL database driver for Qt3 (Threaded
> > ii  libqt4-core                       4.1.3-2                      Qt 4
> > core non-GUI functionality runtime libr
> > ii  libqt4-dev                        4.1.3-2                      Qt 4
> > development files
> > ii  libqt4-gui                        4.1.3-2                      Qt 4
> > core GUI functionality runtime library
> > ii  libqt4-qt3support                 4.1.3-2                      Qt 3
> > compatibility library for Qt 4
> > ii  libqt4-sql                        4.1.3-2                      Qt 4
> > SQL database module
> > ii  libsmokeqt1                       3.5.1-1                      SMOKE
> > Binding Library to Qt
> > ii  libsoqt-dev                       1.3.0-3                      Qt GUI
> > component toolkit for Inventor - deve
> > ii  libsoqt20                         1.3.0-3                      Qt GUI
> > component toolkit for Inventor - runt
> > ii  lsb-qt4                           3.1-10                       Linux
> > Standard Base 3.1 Qt4 support package
> > ii  pinentry-qt                       0.7.2-3                     
> > Qt-based PIN or pass-phrase entry dialog for
> > ii  python-qt3                        3.16-1                       Qt3
> > bindings for Python (default version)
> > ii  python2.3-qt3                     3.16-1                       Qt3
> > bindings for Python
> > ii  qt3-dev-tools                     3.3.6-2                      Qt3
> > development tools
> > ii  qt4-designer                      4.1.3-2                      Qt 4
> > Designer
> > ii  qt4-dev-tools                     4.1.3-2                      Qt 4
> > development tools
> > ii  qtorrent                          2.9.1-5
> > graphical BitTorrent client using Qt 3.x
> > ii  uim-qt                            1.1.0-1.0.1                  Qt 4.x
> > immodule for uim
> >
> > Regards,
> >
> > Leo

-- 
--
Linux User 152692
PGP: 0xF944807E
Catalonia

Attachment: pgpEz6ChXwmu9.pgp
Description: PGP signature


Reply to: