[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install-mbr on amd64?

Scott Reese wrote:
Kilian wrote:
Dear All,

I'm trying to set up a software RAID 1 (two disks) with Debian on a
system with an AMD x86_64 Athlon processor. To install the MBR on both
discs, I need install-mbr (http://packages.debian.org/stable/base/mbr)
if I'm correct, but this package does not exist in the amd64 port... I
then tried to compile it myself, which fails, obviously, because the
package has not been ported to x86_64 yet as it seems (and I lack the
knowledge to do so...).

I'm a bit stuck now.. what other tools can I use?

You don't say what boot loader you're using, but if you are using grub,
you can simply install the MBR to the second disk using the grub terminal.

Thanks a lot for your reply!

I'm using lilo as bootloader, but as grub is way more modern, I might just switch to grub.

The thing is, the machine I'm working on is remote and I have no console access, so everything is a bit tricky. It's already running, has two identical SATA disks, the second one (sdb) is not used. What I want to do is create a RAID 1 array with only sdb (but with the possibility to add sda later). Then I boot from this new RAID array, repartition sda and add it to the RAID array. I've gotten so far as setting up the RAID array, chrooting into it and bootstrap a Debian system on it, compile an new kernel, but when it comes to set up bootloaders, the howto I'm using <http://juerd.nl/site.plp/debianraid> tells me to run:

 $ lilo
 $ install-mbr /dev/sda
 $ install-mbr /dev/sdb

Do you think I could accomplish the same result by only using grub?

	-- Kilian

Reply to: