[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AMD64 port on a Shuttle ST20G5

On Tue, 10 Jan 2006 12:28:06 +0100
Robert Cates <robert@kormar.de> wrote:

> Hi,
> I was wondering if anybody else has a Shuttle ST20G5 with an AMD 64 
> Athlon and has successfully installed the AMD64 port on it.?  I have 
> tried various Linux (x86_64) distros, like Debian 3.1r0, Fedora Core 4, 
> Ubuntu 5.10, Kubuntu 5.10 and Gentoo 2005.1 with mostly a 'kernel panic' 
> at bootup.  In fact, the Debian installer gets to a point and then has a 
> problem accessing the CD drive.  The FC4 installer starts up but when I 
> press enter for the default install, it gives:

I recently got a Shuttle XPC SN95G5V3, with an Athlon 64 (Venice), and --
partly thanks to people on this list, have everything up and running sweetly

Start by getting the debian amd64 version that will recognize your SATA hard
drive (I presume that is what you have -- things are easier with an IDE
drive, so I imagine you have the SATA).  I am looking at to .iso files ---
one of them was the right one.  sarge-amd64-2.6.12-netinst.iso or
debian-testing-amd64-netinst.iso.  I think it's the first one that you want,
since you do need a 2.6.12 kernel to recognize a SATA drive.  Then go through
that installation, and finish over the net installing etch (testing) -- or if
you are more adventurous, go with the unstable.  Maybe the unstable
netinstall image will work right out of the box, but I donno.

I ran into one extra problem, in that the CD was no longer recognized once
the install was finished.  But there was a procedure I got from the helpful
folks on this list to work around that, to get it to first look for ide
devices, then sata, since otherwise it tried to treat the cd using scsi
emulation, which was really buggy.  I'll scrounge those up for you if you
can't get it to run, and can't find archives of this list.

BTW, I also managed to install a 64-bit version of Maple 10 on this machine
-- despite the poor installation program they use.  If you want details on
that, I can help.

> At first I thought this might have something to do with the built-in ATI 
> X200 Radion IGP, 

I have a (non-builtin) Radion that works fine.

so I bought an Nvidia PCI-e card, but no change.  

My understanding is that nvidia is more difficult to get working than Radion.

> upgraded the BIOS on the Shuttle to the newest available - ft20s018, and 
> I've made various changes to the BIOS, all with no change.  I've tried 
> with APCI disabled, assigning an IRQ to the video and USB enabled and 
> disabled, and other options enabled and disabled, but nothing helps.
I haven't changed anything from the original BIOS.  My machine is a little
different from yours, but not that much.

> If anybody has a solution I'd greatly appreciate it.  I really thought 
> this was good hardware when I bought it (specifically for the AMD64 
> port), so I'd hate to think I've waisted my money.

Rest assured.  


David L. Johnson

   __o   | "A foolish consistency is the hobgoblin of little minds, adored 
 _`\(,_  | by little statesmen and philosophers and divines." --Ralph Waldo
(_)/ (_) | Emerson  

Reply to: