[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

CDROM Resolved. Re: SUCCESS: Re: First Kernel Build Attempt Failed was: Re: 3ware 9550 SATA RAID controller problems

Resolved the CDROM recognition problem.

create a file named libata into /etc/modprobe.d/
with the content:
options libata atapi_enabled=1


# dpkg-reconfigure linux-image-`uname -r`

This regenerate the initrd image with the special parameter.

It tried to pass libata.atapi_enabled=1 at boot params but didn't worked.

I now have /dev/sr0 and can mount a read the CDROM.


Lennart Sorensen wrote:
On Sun, Jan 08, 2006 at 10:42:20AM -0500, Stephen Woodbridge wrote:

Hi Len,

Thank You! Thank you! Thank you! Using the kernel from sid did the trick! I guess I was too focused on having to build a kernel to step back from the problem and see that. Also the kernel-image to linux-image tripped me up so I didn't see them in apt-cache search.

I now can see the 3ware device as /dev/sdb but I seem to have lost the CDROM drive again. I suppose the 2.6.15 wants the BIOS settings changed again or I have run up against the problem that the CDROM seems to only run as a slave device on the PATA IDE bus.

Any idea what causes the:

ata1(1): WARNING: ATAPI is disabled, device ignored.

There is an option I think might have to be enabled.  There is also a
bug in 2.6.15 that I just read on lkml about 30 minutes ago, that on
intel ICH controllers, PATA secondary slave is currently broken.
primary master, primary slave, and secondary master all work, but no
atapi on secondary slave.

If your cdrom is secondary slave, change it.

Otherwise look for the libata.atapi_enabled=1 or something option and add
that to the module options, or the kernel boot command.  Might have to
add it to the initrd configuration and generate a new initrd with that
option enabled.  yaird has a config file where you can list modules to
load, and modules options and such.  Adding it to the kernel boot
options might work too.

SCSI subsystem initialized
libata version 1.20 loaded.
ata_piix 0000:00:1f.2: version 1.05
ata_piix 0000:00:1f.2: combined mode detected (p=0, s=1)
GSI 17 sharing vector 0xB1 and IRQ 17
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: PATA max UDMA/100 cmd 0x1F0 ctl 0x3F6 bmdma 0x1470 irq 14
ata1: dev 1 cfg 49:0f00 82:4210 83:4000 84:4000 85:0000 86:0000 87:4000 88:0407
ata1: dev 1 ATAPI, max UDMA/33
ata1: dev 1 configured for UDMA/33
scsi0 : ata_piix
ata1(1): WARNING: ATAPI is disabled, device ignored.
ata2: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0x1478 irq 15
ata2: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3c01 87:4023 88:207f
ata2: dev 0 ATA-7, max UDMA/133, 488397168 sectors: LBA48
ata2: dev 0 configured for UDMA/133
scsi1 : ata_piix
 Vendor: ATA       Model: WDC WD2500JS-00N  Rev: 10.0
 Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
SCSI device sda: drive cache: write back
sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 >
sd 1:0:0:0: Attached scsi disk sda

Yeah I think the libata.atapi_enabled option would help.

Len Sorensen

Reply to: