[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with NICs on Amd64 installer

On Friday 18 November 2005 16:48, Lennart Sorensen wrote:
> On Thu, Nov 17, 2005 at 10:08:40AM +0000, David Goodenough wrote:
> > Of course I could not do an lspci with the installer, as it is not
> > present (why, it would be so useful), so I used Knoppix instead.
> >
> > The raid card is:
> >
> > 1044:a511 RAID controller Adaptec (formerly DPT) SmartRAID V Controller
> >                 rev 1
> >
> > and the network cards:-
> >
> > 14e4:1640 Broadcom NetXtreme BCM5704.
> >
> > With your driver in exprt mode it correctly identified the cards and the
> > drivers that were needed for them, but said they could not be loaded.
> Hmm, well the raid card appears to be supported by the i2o drivers, so
> perhaps if you manually modprobe those from console 2 it would work.  I
> haven't worked with i2o myself, but I know I included them on my
> installer cd.
> ie: drivers/message/i2o/pci.c:    {PCI_DEVICE(PCI_VENDOR_ID_DPT, 0xa511)}


I tried loading this manually (I notice in expert mode that there is a message
saying that it needed this driver but could not find it) but it does not 
appear to be there.  My guess (but only a guess) is that it is not in the
initrd image.  It certainly is not in the 
/lib/modules/2.6.12.../kernel/drivers/scsi directoryat the time that it
comes to load the CD driver.


> As for the network, those might be among the broadcoms that require the
> bcm5700 driver instead of the tg3 driver.  That one is not included in
> the kernel at all, but has to be installed from the bcm5700-source
> package after installing.  Insert a more standard NIC to do the install
> with until you can get the broadcom working I guess.
> Len Sorensen

Reply to: