[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel compilation failure


> > 
> > Stubbornly, I tried again (compiling under,
> > and this time, it worked!
> > And again, 5 or 6 times, no segmentation fault, no crash.
> > 

I spoke too quickly :-{
Seemingly, it was just a short-lived miracle.  Now I have these
general protection faults at every compilation attempt, each time
at a different step, and not always for the same program:

Sep 29 20:11:10 dusk kernel: [31047.241928] rm[11316] general protection rip:2aaaaaaac80e rsp:7fffff9c0fa0 error:0
Sep 29 20:21:16 dusk kernel: [31653.305200] mv[32625] general protection rip:2aaaaaaac80e rsp:7ffffffc1680 error:0
Sep 29 21:00:50 dusk kernel: [34026.992832] mv[21793] general protection rip:2aaaaaaac80e rsp:7fffffbc08b0 error:0

> > But, even stranger, I also tried to compile a 2.6.10 and a 2.6.11
> > kernel, and for those, I consistently get:
> > 
> > [...]
> binutils 2.16 fixed a bug, which unfortunately whacks older kernels'
> assembly code.  I think 2.6.12 includes the fixes already.

OK.  This explains the other failures.

But for the problem above, I'm stuck. This was suggested (on the AMD
forums) as a possible cause:

Also, I (and many others) had horrible experiences with the Silicon Image
controllers on todays motherboards -- if your system begins to use swap
during build and you use SATA drive(s), your paged-out memory may 
occasionally be corrupted

[I have SATA_sil 3114 (BIOS 5.037) onboard.]

Also, other people seem to have the similar (?) problems, also with
Tyan Opteron MBs:


Is there a way to be sure it is, or not, a kernel bug?  Or a hardware


Reply to: