[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Tracking sarge

On Feb 15, 2005, at 10:36 AM, Goswin von Brederlow wrote:

Kurt Yoder <ktydeb@richard-group.com> writes:

On Feb 15, 2005, at 3:29 AM, Goswin von Brederlow wrote:
That is the right one. My /usr/share/initrd-tools/scripts/e2fsprogs
contains the following line:

LIBS=`ldd $PROGS | grep -v linux-gate.so | sort -u | \

This looks like a partial line? I definitely don't have a line like
that in my /usr/share/initrd-tools/scripts/e2fsprogs though.

That is very strange. Maybe someone patched it for amd64 and forgot to
increase the version. I will check into that.

I just noticed that, according to "find", there is no "linux-gate.so" on the system. I am unfortunately lacking in knowledge here. But if there is no linux-gate.so on the system, wouldn't I be OK without the "grep -v"?

Sorry if that is an irrelevant question...


root@ns2:/tmp# apt-get install kernel-image-2.6.8-10-amd64-generic
2>&1 | tee log
Reading Package Lists...
Building Dependency Tree...
Suggested packages:
   lilo kernel-doc-2.6.8
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 48 not upgraded.
Need to get 12.6MB of archives.
After unpacking 42.8MB of additional disk space will be used.
Get:1 http://mirrors.kernel.org testing/main
kernel-image-2.6.8-10-amd64-generic 2.6.8-11 [12.6MB]
Fetched 12.6MB in 47s (266kB/s)
Selecting previously deselected package
(Reading database ... 21247 files and directories currently installed.)
Unpacking kernel-image-2.6.8-10-amd64-generic (from
.../kernel-image-2.6.8-10-amd64-generic_2.6.8-11_i386.deb) ...
Setting up kernel-image-2.6.8-10-amd64-generic (2.6.8-11) ...
cpio: (0x00000000): No such file or directory

This is before the /usr/share/initrd-tools/scripts/e2fsprogs starts or
sh -x would have shown some output already. So another script is buggy
and needs to be fixed for the 32bit emulation.

Ah. Then it looks to me like *something* is generating (or trying to generate) a file. But the script thinks the file is named "(0x00000000)", when in actuality it should be named something else? So maybe the e2fsprogs script is OK?

Do you have any ideas what script might be generating the "cpio: (0x00000000): No such file or directory" message?

Now /usr/share/initrd-tools/scripts/e2fsprogs starts:

+ cp /usr/share/e2fsprogs/initrd.ext3-add-journal
+ cp /sbin/tune2fs /tmp/mkinitrd.4463/initrd/sbin
+ cp /usr/bin/awk /tmp/mkinitrd.4463/initrd/bin/awk
++ ldd /sbin/tune2fs /usr/bin/awk

Here the '| grep -v linux-gate.so' would be in my script. The rest is
clear, without the grep it misbehaves.

I guess I don't understand. I see:

(... snipped normal-looking output of e2fsprogs...)
+ mkdir -p /tmp/mkinitrd.4982/initrd//lib
+ cp /lib/libuuid.so.1 /tmp/mkinitrd.4982/initrd//lib/libuuid.so.1
++ dirname '/tmp/mkinitrd.4982/initrd/(0x00000000)'
+ mkdir -p /tmp/mkinitrd.4982/initrd
+ cp '(0x00000000)' '/tmp/mkinitrd.4982/initrd/(0x00000000)'
cp: cannot stat `(0x00000000)': No such file or directory
run-parts: /usr/share/initrd-tools/scripts/e2fsprogs exited with return code 1

So unless I am mistaken, it seems like a bogus file name "(0x00000000)" is being set around the time I see the "cpio: No such file" message. e2fsprogs is unable to find the "0x00" file and gives up. So whether or not the "| grep -v linux-gate.so" is there, wouldn't I always get the same result?

I suppose I could re-run the "regular" (32-bit x86) Debian installer to put me back on a 32-bit kernel and quit bothering everyone about this. However, I've noticed quite a few people who are having this problem (I run a blog where I posted about this error, and a lot of people seem to be looking for information on the error via search engine queries). So I'd prefer to fix and document the problem so everyone can benefit.


Kurt Yoder

Reply to: