[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AMD64 installation problem

Tobias wrote:

-- > Hi,

first of all I want to thank anyone who made this AMD64 port possible.
But now here are my experiences:

The system is a MSI K8N Neo4 Platinum (S939 nForce4 Ultra) with a SATA-2 HDD on the primary nForce SATA-2 port. For my first installation attempt I used the 125MB netinst iso (2005-01-24 I think). Installation worked quite fine with that one exception that it had no networking modules and no support for [reiserfs | ext3 | xfs ] so I had to use ext2 which I really don't like for a desktop system. But after installation I was able to boot it up using grub which was installed at the last step of the installer.

Because I definitely want a journalling FS (no ext3 <--> reiserfs flamewar now , please) I tried to make a new install using mini.iso (2005-02-10). I had both, the normal and the monolithic one. The monolithic failed when trying to debootstrap so I had to use the non-monolithic one. With it installation worked fine (with one little exception, it didn't automatically detect my network hardware, I had to load forcedth.ko by hand), I selected debian-amd64.alioth.debian.org as mirror and /pure64/ as mirror folder, reiserfs ok, debootstrap ok, installing base system ok, installing grub ok. Then when installer finished it reboots the system but now grub won't start, it only gives me a dead loop of the line Grub loading stage 1.5 repeating again and again. Btw. the HDD is detected as /dev/sda using sata_nv.ko, is this correct). Also tried this with ext3 and xfs, same problem.
Any ideas what I might be doing wrong?
Thanks in advance,


I have tried the 2005-01-24 netinst iso finally and want to correct my previous response. The 24 January did not have the journaling filesystems option exactly as you said. The networking modules were missing in my attempt also.

I did try the 11 Feb netinst iso not the 10 Feb mini iso. I had no problems with the 11 Feb netinst except I did not try the grub bootloader so I don't know if that would fail the same as the 10 Feb mini iso. The 11 Feb netinst also had the ReiserFS, XFS, ext3 and I made a filesystem in my partition with each of those without any problems.

I have tried the 13 Feb monolithic iso and that also failed trying to debootstrap the same as the 10 Feb monolithic.

The 11 Feb netinst was the best installer I tried. I don't know if the grub worked because I continued without a bootloader and used my current kernel to boot into the partition. The network was properly detected and configured and my SATA worked fine before the reboot so the kernel should have worked. I have a VIA SATA not nVidia SATA so the results could be different. If the grub works then I think the 11 Feb netinst is a good Installer.

The Debian Installation Manual (for i386) says there is a step where the Installer can be used to boot a partition except I haven't found that feature in the 11 Feb netinst. The page 37 mentions a step called 'Mount a Previously Initialized Partition' using Lilo or Grub if I understand. I don't use those bootloaders so am not certain. Goswin mentioned problems preventing the Installer from booting a previously initialized partition so that could be a problem. If you are a grub user then maybe grub can be manipulated by hand to find the kernel when rebooting. The DFS could also be used if grub fails. The /boot/grub/menu.lst contains the grub instructions so that could be checked for obvious errors before rebooting and maybe grub rerun to correct an error. That is a little outside my experience so I hope you have more experience there.

I now recommend the 11 Feb netinst iso instead of the 24 January netinst iso recommended in my first comment. There has been a lot of progress recently.

Good Luck.


AMD Athlon 64 2.4Ghz Corsair TwinX1024-3200XL DDR 480Mhz ASUS A8V Deluxe ASUS Radeon A9250Ge/Td/256 Creative SB Live! WD Raptor SATA Maxtor PATA IBM/Okidata Color Postscript3 Lexmark Mono Postscript2 Debian GNU/Linux debian-amd64/pure64 sid XFree86 4.3.0 Xorg X11R6.8.2 1.5 Mb DSL

Reply to: