[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Time to test sarge

Goswin wrote:

I exited the base config and tried dselect and there
were conflicts with dependency on libc6. The
libc6-dev depends on libc6 = 2.3.2.ds1-20 and libc6
was version 2.3.2.ds1-

I think that would be fixed in a day or two.
I think everything will work after sarge is updated to
yesterdays sid.

No, patched sources/debs don't enter sarge (not
automatically, not yet). This needs manual fixing, see

I have tried another image and the same problem occurs:
sid-amd64-netinst.iso 24-Jan-2005 08:46 126M

That confirms sarge libc6-dev is at least 17 days later.
Both the 11Feb and 24Jan images must have been built from
sid containing the libc6 2.3.2.ds1- package
except sarge libc6-dev requires libc6 2.3.2.ds1-20. I would
need to try a netinst built from libc6 <= 2.3.2.ds1-20 to
avoid the need to downgrade. I could try a very old
installer from way last year and then everything in sarge
would be an upgrade.

I'm plaing to downgrade the sid libc6 to an unpatched
form to fix this. The patch was only needed for upgrades
and hopefully everyone has done so now. Any objections?

Now I'm confused about that. Was the patch to do with
linking /lib/amd64?

I have downgraded packages before using dpkg not using
apt-get or dselect. These problems should be blamed on the
installer not on sid. Please don't experiment with the
most excellent sid for this reason.

* Could you post an iso built from the sarge packages? *

Maybe the same routine used to build the 11Feb images only
build * from * sarge * instead * of * sid.

Is the point of sarge to build a full CD image to install
without a network? That is going to need a sarge installer.

I forgot how to build my own image from the files so I would
need to actually read the manual to make my own. None of the
recent install-images are suitable for installing sarge.


Reply to: