[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dependency issue with perl-base

Hi Debian fans,

I found the solution and thought I post it here for others.

The original cause was finally found to be the locale settings. I will walk 
all the way once again so its easy to follow. 

1) When trying to update perl I evt. found out that something is wrong with 
the locale settings

"Do you want to continue? [Y/n] Y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = "ja_JP:ja:en_GB:en",
  LC_ALL = "en_US",
   LANG = "ja_JP.EUC-JP"
       are supported and installed on your system.
       perl: warning: Falling back to the standard locale ("C").
       locale: Cannot set LC_CTYPE to default locale: No such file or 
       locale: Cannot set LC_MESSAGES to default locale: No such file or 
       locale: Cannot set LC_ALL to default locale: No such file or directory


2) So I checked the file /etc/locale.gen and unfortunately it was completely 
empty (which is not good)

2a) So I did a "man locale" and read which locales I can / should put.

So I ended up with a file like this

--------------contents of /etc/local.gen---------------------
en_GB ISO-8859-1
en_US ISO-8859-1
en_US ISO8859-1
en_GB.ISO-8859-15 ISO-8859-15
en_GB.UTF-8 UTF-8
ja_JP.UTF-8 UTF-8

2b) I did a "locale-gen"

ns1:/home/nilsv# locale-gen
Generating locales...
  ja_JP.EUC-JP... done
  en_GB.ISO-8859-1... done
  en_US.ISO-8859-1... done
  en_US.ISO8859-1... done
  en_GB.ISO-8859-15... done
  en_GB.UTF-8... done
  ja_JP.UTF-8... done
Generation complete.

3) I removed the "liblockfile-simple-perl" package

"dpkg --remove liblockfile-simple-perl"

4) Now I did my upgrade.

"apt-get upgrade"

So finally everything is fine and system is up and running.

I hope that helps somebody to avoid wasting their time on such issues.

Best regards

Nils Valentin
Tokyo / Japan


On Tuesday 08 February 2005 10:02, valentin_nils@be-known-online.com wrote:
> Hi Debian fans,
> I tried to upgrade my system and run into an dependency issue.
> 1) First I thought this was down to the fact that I set the locales to
> UTF-8, so I removed those settings (below).
> ----------
> ns1:/home/nilsv# locale
> 2) But,when I try to upgrade perl-base than I get a dependency issue which
> I cant resolve. I tried to force it, but no luck. (below)
> -----------
> ns1:/home/nilsv# apt-get upgrade
> Reading Package Lists... Done
> Building Dependency Tree... Done
> You might want to run `apt-get -f install' to correct these.
> The following packages have unmet dependencies:
>   libperl5.8: Depends: perl-base (= 5.8.4-6) but 5.8.4-5 is installed
>   perl: Depends: perl-base (= 5.8.4-6) but 5.8.4-5 is installed
> E: Unmet dependencies. Try using -f.
> ns1:/home/nilsv# apt-get upgrade -f
> <snip>
> Do you want to continue? [Y/n] Y
> Preconfiguring packages ...
> (Reading database ... 95329 files and directories currently installed.)
> Preparing to replace perl-base 5.8.4-5 (using
> .../perl-base_5.8.4-6_amd64.deb) ...
> Unpacking replacement perl-base ...
> dpkg: error processing /var/cache/apt/archives/perl-base_5.8.4-6_amd64.deb
> (--unpack):
>  trying to overwrite `/usr/lib/perl/5.8', which is also in package
> liblockfile-simple-perl
> Errors were encountered while processing:
>  /var/cache/apt/archives/perl-base_5.8.4-6_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> ------
> Any suggestions are much appreciated.
> Best regards
> Nils Valentin
> Tokyo / Japan
> http://www.be-known-online.com

kind regards

Nils Valentin


Reply to: