[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pivot_root: No such file or directory



This is only important because i _really_ want to compile my own customized kernel,
and I haven't done this since 2.0.21, I think it was...

And I'm trying to get into kernel customizing in general.

I probably should put this question in some other mailing-list, but since the amd64 port is a really evolving port, 
problems and solutions are more like a day2day issue.



Harald Dunkel (harald.dunkel@t-online.de) wrote:
> In The Night wrote:
> >Hmmm....
> >I've tried that.
> >I've tried mkinitrd -r /dev/sdb1 too...
> >
> >The problem seems to be me having root on a SATA-drive....
> >
> 
> mkinitrd fails to find the sata driver necessary to mount
> your root disk. See
> 
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=263169
> 
> Workaround is to add your sata driver to /etc/mkinitrd/modules
> and rebuild the initrd.
> 
> 
> What I _really_ do not understand is why this is not seen
> as a serious problem.
> 
> 
> Regards
> 
> Harri

-- 
.O.	Scream, Scream like the silence of the bits.
..O	Dead lies the flag by the feet of the cold one.
OOO	Freedom WILL break the walls of mammon.

Attachment: pgpJRSpsNzXn7.pgp
Description: PGP signature


Reply to: