[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pivot_root: No such file or directory (was: Lots of PREEMPT on 2.6.7-6 and 2.6.7-3. 2.6.8-3 panics before mounting anything.)



Hmmm....
I've tried that.
I've tried mkinitrd -r /dev/sdb1 too...

The problem seems to be me having root on a SATA-drive....

My menu.lst-entry is for 2.6.7 (working):

title           Debian GNU/Linux, kernel 2.6.7
root            (hd0,2)
kernel          /vmlinuz-2.6.7 root=/dev/hdg1 ro
initrd          /initrd.img-2.6.7
savedefault
boot

My menu.lst-entry is for 2.6.8 (non-working):

title           Debian GNU/Linux, kernel 2.6.8-3-amd64-k8
root            (hd0,2)
kernel          /vmlinuz-2.6.8-3-amd64-k8 root=/dev/sdb1 ro 
initrd          /initrd.img-2.6.8-3-amd64-k8
savedefault
boot


Suggestions?

I have two different /etc/fstab with either hdg and sdb



Patrick Flaherty (patrick@activmedia.com) wrote:
> Hacking initrd seems overkill....
> next time you boot go down to the line in grub that says 
>  kernel /vmlinuz root=/dev/hdXX
> to
>  kernel /vmlinuz root=/dev/sdXX
> 
> sdXX should be the drive and your root partition. (e.g. first sata
> drive, second partition sda2)
> 
> A long convoluted answer on why this happens can be found else where,
> lets just go with the sata drives are intepreted as scsi drives cause
> they have more in comon than standard ide drives.
> 
> cheers
> patrick



-- 
.O.	Scream, Scream like the silence of the bits.
..O	Dead lies the flag by the feet of the cold one.
OOO	Freedom WILL break the walls of mammon.

Attachment: pgp1tzW0uV8R1.pgp
Description: PGP signature


Reply to: