[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub testers wanted

Miham KEREKES <miham@bibl.u-szeged.hu> writes:

> Hi All,
>> everyone with 4GB or more or who had problems with grub in the past
>> should test the lates grub with and inited kernel and send a short
>> reply if it works or what the error is.
> I've updated grub in this morning to version 0.95+cvs20040624-
> from debian-amd64.alioth.debian.org, and tried to boot up an initrd kernel 
> afterwards with the following result:
> ===========================================================
>   Booting 'Debian GNU/Linux, kernel 2.6.7-5-amd64-k8-smp '
> root  hd(0,0)
>  Filesystem type is ext2fs, partition type 0x83
> kernel  /boot/vmlinuz-2.6.7-5-amd64-k8-smp root=/dev/sda1 ro
>    [Linux-bzimage, setup=0x1400, size=0x131381]
> initrd  /boot/initrd.img-2.6.7-5-amd64-k8-smp
>    [Linux-initrd @ 0xbfb88000, 0x458000 bytes]
> Error 28: Selected item cannot fit into memory

Lets see if I can understand that code and add some more debug in
there for the next upload.

> ===========================================================
>> Please include what motherboard, cpu, ram and kernel/initrd you use.
> MB: Tyan Thunder S2882 (K8S Pro), BIOS revision 2.03
> CPU: 2 x Amd Opteron 244 [1.8GHz]
> RAM: 8 x 1GB Kingston ValueRam
> Kernel and initrd: see above


> Related BIOS setting:
> MTRR Mapping: Continuous  [PCI hole described as non-cacheable]

Have you tried changing this?

>> Reports of it failing have been sketchy and the suggested patch seems
>> to only help some people so we need some statistics to see whats going
>> on and to find test candidates for future patches.
> Last time the result was same as above, so patch didn't help for me :-(
> I'm able to boot any kernel without initrd with grub.
> I'll gladly test any further version of grub.
> Thanks,
> 	Miham.

Does the error also appear with exactly 4GB ram? With 2GB it works,


Reply to: