[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: amd64 installter (Debian From Scratch)

On Wed, 2004-05-26 at 11:03, Piotr Kopszak wrote:
> Hi, 
> Tried yesterday the DFS live CD, and it's pretty amazing! First live
> CD with 64-bit system that I was able to run on my computer. Quite
> historic. Installation of debian64 fails however,, probably at the
> same spot, as mentioned in one of the earlier messages. From what the
> cdebootstrap wanted to say to me I gather it's a libc package
> problem. Here is an  exerpt from the install session log. I can send it
> if anyone is interested. 
i would second this opinion.. 
tring to install glibc with dpkg after chrooting in the created
environment complains about a wrong kernel version (something about the
minor version > 255 or like that)
in fact, the amd64 kernel is named 2.6.6amd64 and should be
2.6.6-amd64... (the libc6 install check seems to fail when it tries to
get a number out of 6amd64 missing a separator)

> [...]
> O: Selecting previously deselected package gzip.
> O: dpkg: regarding .../gzip_1.3.5- containing gzip, pre-dependency problem:
> O:  gzip pre-depends on libc6 (>= 2.3.2.ds1-4)
> O: dpkg: warning - ignoring pre-dependency problem !
> O: Unpacking gzip (from .../gzip_1.3.5- ...
> P: Unpacking package gzip
> D: Progress bar - set to 623
> D: Updating gzip to status 2
> O: Errors were encountered while processing:
> O:  /var/cache/apt/archives/libc6_2.3.2.ds1-12.pure64.2_amd64.deb
> D: Stop progress bar (max: 1000, act: 623) - implicit
> E: Couldn't install root!
> dfs:~# 

also the howto suggest using cdebootstrap 0.2.5 or later...
the dfs cd uses sarge with cdebootstrap 0.2.4.. .don't know if thats a
problem though (at least using cdebootstrap 0.2.5 didn't help from the
dfs cd)

Sven Matner

Tyan Thunder K8W
dual opteron 242
2 GB ram

Reply to: