[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

perl DBD buidl problems


i run the latest pure64 debian system here. when compiling the
perl DBD::mysql package, the following error occurs. compiling
DBI and mysql itself worked fine.

netskin2:~/.cpan/build/DBD-mysql-2.9003# perl Makefile.PL
I will use the following settings for compiling and testing:

  cflags        (mysql_config) = -I/usr/local/mysql/include/mysql -march=athlon-mp -mmmx -msse -msse2 -m3dnow -fomit-frame-pointer -fexpensive-optimizations -mfpmath=sse,387 -pipe
  libs          (mysql_config) = -L/usr/local/mysql/lib/mysql -lmysqlclient -lcrypt -lnsl -lm
  nocatchstderr (default     ) = 0
  nofoundrows   (default     ) = 0
  ssl           (guessed     ) = 0
  testdb        (default     ) = test
  testhost      (default     ) =
  testpassword  (default     ) =
  testuser      (default     ) =

To change these settings, see 'perl Makefile.PL --help' and
'perldoc INSTALL'.

Using DBI 1.42 (for perl 5.008004 on x86_64-linux-thread-multi) installed in /usr/local/lib/perl/5.8.4/auto/DBI
Writing Makefile for DBD::mysql
netskin2:~/.cpan/build/DBD-mysql-2.9003# make -j4
cc -c  -I/usr/local/lib/perl/5.8.4/auto/DBI -I/usr/local/mysql/include/mysql -march=athlon-mp -mmmx -msse -msse2 -m3dnow -fomit-frame-pointer -fexpensive-optimizations -mfpmath=sse,387 -pipe -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2   -DVERSION=\"2.9003\" -DXS_VERSION=\"2.9003\" -fPIC "-I/usr/lib/perl/5.8/CORE"   dbdimp.c
Running Mkbootstrap for DBD::mysql ()
chmod 644 mysql.bs
cc -c  -I/usr/local/lib/perl/5.8.4/auto/DBI -I/usr/local/mysql/include/mysql -march=athlon-mp -mmmx -msse -msse2 -m3dnow -fomit-frame-pointer -fexpensive-optimizations -mfpmath=sse,387 -pipe -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2   -DVERSION=\"2.9003\" -DXS_VERSION=\"2.9003\" -fPIC "-I/usr/lib/perl/5.8/CORE"   mysql.c
cp mysql.bs blib/arch/auto/DBD/mysql/mysql.bs
chmod 644 blib/arch/auto/DBD/mysql/mysql.bs
rm -f blib/arch/auto/DBD/mysql/mysql.so
LD_RUN_PATH="" /usr/bin/perl myld cc  -shared -L/usr/local/lib dbdimp.o mysql.o  -o blib/arch/auto/DBD/mysql/mysql.so   -L/usr/local/mysql/lib/mysql -lmysqlclient -lcrypt -lnsl -lm
/usr/bin/ld: /usr/local/mysql/lib/mysql/libmysqlclient.a(libmysql.o): relocation R_X86_64_32S can not be used when making a shared object; recompile with -fPIC
/usr/local/mysql/lib/mysql/libmysqlclient.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/DBD/mysql/mysql.so] Error 1

by the way: does it hurt to tune the kernel makefile with
options like "-O3 -mmmx -msse -msse2" etc...? why isnt this
the default, doesn't it speed up the kernel a lot?


Reply to: