[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re [2]: java 1.7on AlphaServer


Well.. why not? I liked it running OpenBSD but OpenBSD is missing java for alphas :( . Will try to install the latest unstable Debian and java... 

Anyway.. I tried to follow the instruction by Tom Hogland, but stuck with the liblzma install - then I try to execute "dpkg -i liblzma5_5.1.1alpha+20120614-2_alpha.deb" (i can`t find  liblzma2, only liblzma5) got the following: 

# dpkg -i liblzma5_5.1.1alpha+20120614-2_alpha.deb 
Selecting previously deselected package liblzma5. 
dpkg: regarding liblzma5_5.1.1alpha+20120614-2_alpha.deb containing liblzma5, pre-dependency problem: 
 liblzma5 pre-depends on multiarch-support 
  multiarch-support is not installed. 
dpkg: error processing liblzma5_5.1.1alpha+20120614-2_alpha.deb (--install): 
 pre-dependency problem - not installing liblzma5 
Errors were encountered while processing: 

I can`t find the "multiarch-support" package at  http://ftp.debian-ports.org , maybe it is located at other location? 

Best regards, 

--- Исходное сообщение --- 
От кого: Oliver Falk < oliver@linux-kernel.at > 
Дата: 04 июня 2014, 18:53:56 

Hi!   Are you sure you want to run Java on an Alpha machine? Java makes heavy use of gettimeofday, which is a quite expensive systemcall on that hardware :-/   Best, Oliver   From: maed@ukr.net [mailto:maed@ukr.net] 
Sent: Wednesday, June 04, 2014 10:22 AM 
To: debian-alpha@lists.debian.org 
Subject: java 1.7on AlphaServer   Greetings! 

I bout the AlphaServer DS25 about year ago (like big-and-heavy hardware :) ). I successfully installed Debian 5.0.10 (the latest Debian for alphas?) in order to run some java software, but installing openjdk7 seems to be a problem. 
There is a rather new port (package) called "openjdk-7-jre" witch seems to support alpha systems ( https://packages.debian.org/sid/java/openjdk-7-jre ), but just executing "apt-get install openjdk-7-jre" won`t work - I got the "file  [file] contains ununderstood data member data.tar.xz, giving up" error. I tried to update dpkg itself, but this also failed :( ... 
Anyone have the openjdk7 running on alphas? If yes, than what version of Debian? Is there any docs, tutorial or recomendations? 

Best regards? 


Reply to: