[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Using debootstrap to install from Debian-Ports [was Re: qLogic and wheezy]

--On Monday, July 09, 2012 10:53:12 PM +1200 Michael Cree <mcree@orcon.net.nz> wrote:

On 09/07/12 10:36, Bill MacAllister wrote:
--On Sunday, June 17, 2012 09:22:38 PM +1200 Michael Cree
<mcree@orcon.net.nz> wrote:

And, yes, there is an alternative:

Use debootstrap from a working computer to install straight to unstable.

Done, instructions are at the AlphaLinux wiki:


Thanks for this write up.  I have been working through these
instructions and hit a couple bumps ending in a road block.  I am
using a PWS running lenny with a 2.6.18-5-alpha-generic kernel.

A Lenny kernel will definitely not be sufficient.  Unfortunately neither
will the lenny-backports kernel suffice on Alpha, mainly because of many
missing syscalls.

* The debootstrap on lenny does not support the --private-key switch.

The Lenny debootstrap might be problematic.  I used the debootstrap from
lenny-backports -- I see that I have version 1.0.25~bpo50+1 installed in
the Lenny partition.

Ahh, added the following to get the new debootstrap installed.


   deb http://archive.debian.org/debian-backports lenny-backports   main
   deb http://archive.debian.org/debian-backports lenny-backports-sloppy main


   Package: *
   Pin: release n=lenny-backports
   Pin-Priority: 200

   Package: *
   Pin: release n=lenny-backports-sloppy
   Pin-Priority: 200

   Package: debootstrap
   Pin: version 1.0.25*
   Pin-Priority: 900

 The command I used was:

    # debootstrap sid /mnt http://ftp.debian-ports.org/debian

which probably needs some extra trickery to get debootstrap to verify
the archive key somehow, of which I did work how to do once but I've now

And now the the command you documented is accepted.

    # mount proc /mnt/proc/ -t proc

Thanks, now updated on the wiki.

* The directory /dev/pts was not created in the new root.

Updated wiki with that.

I would have updated this myself, but when I clicked on the "To obtain
a user account, you must request one" link I got a blank page.  Is there
someone I should talk to about getting access?

* When I tried to enter the chroot I got the error:

Blah, shouldn't have had that second margarita.  This should have

* Here is the end of the output from the debootstrap command.

    # LANG=C chroot /mnt /bin/bash
    ... lots of validating ...
    ... lots of extracting ...
    I: Extracting zlib1g...
    W: Failure trying to run: chroot /mnt mount -t proc proc /proc

I bet this is the kernel issue.

I'm not sure what is going on here.

* Then when I attempted to enter the chroot I hit the road block.

    # LANG=C chroot /mnt /bin/bash
    FATAL: kernel too old

Yep, you definitely need a much newer kernel than the Lenny kernel :-(

* Then I tried it upgrade the lenny kernel with the kernel from

Sorry, but I think those kernels are missing a syscall needed for udev.
 I've just updated them now.

Hmmm, the *.deb's look the same to me.  Maybe you updated the source
only and I should build the kernel myself?

When I try and boot that
 kernel I get the error:

    halt code = 2
    kernel stack not valid halt
    PC = 200000000

I've never seen that error before.

I did try downloading the kernel again and I am getting the same
error.  Not sure what is deal is.  I'll work on it some more tomorrow

Hmmm, let me include a list of the contents of /boot and the
aboot.conf I am using just incase there is something you can see that
I am doing wrong.

% ls -l
total 41479
-rw-r--r-- 1 root root    81408 2008-06-02 13:06 bootlx
-rw-r--r-- 1 root root    64371 2007-12-22 12:34 config-2.6.18-5-alpha-generic
-rw-r--r-- 1 root root    79059 2012-03-04 12:52 config-2.6.26-2-alpha-generic
-rw-r--r-- 1 root root    91944 2011-08-10 15:51 config-2.6.32-bpo.5-alpha-generic
drwxr-xr-x 2 root root     1024 2012-07-08 13:58 etc
lrwxrwxrwx 1 root root       33 2012-06-13 02:46 initrd.img -> initrd.img-2.6.18-5-alpha-generic
-rw-r--r-- 1 root root  7713596 2012-06-13 03:13 initrd.img-2.6.18-5-alpha-generic
-rw-r--r-- 1 root root  6379354 2012-06-13 02:42 initrd.img-2.6.18-5-alpha-generic.bak
-rw-r--r-- 1 root root  9241806 2012-07-08 12:46 initrd.img-2.6.26-2-alpha-generic
-rw-r--r-- 1 root root 10792386 2012-07-10 00:16 initrd.img-2.6.32-bpo.5-alpha-generic
lrwxrwxrwx 1 root root       37 2012-07-10 00:17 initrd.img.new -> initrd.img-2.6.32-bpo.5-alpha-generic
drwxr-xr-x 2 root root    12288 2012-06-13 02:29 lost+found
-rw-r--r-- 1 root root    29184 2008-06-02 13:06 net_aboot.nh
-rw-r--r-- 1 root root      512 2008-06-02 13:06 net_pad
-rw-r--r-- 1 root root   804792 2007-12-22 16:38 System.map-2.6.18-5-alpha-generic
-rw-r--r-- 1 root root   972856 2012-03-04 18:22 System.map-2.6.26-2-alpha-generic
-rw-r--r-- 1 root root  1110442 2011-08-10 15:51 System.map-2.6.32-bpo.5-alpha-generic
lrwxrwxrwx 1 root root       30 2012-06-13 02:46 vmlinuz -> vmlinuz-2.6.18-5-alpha-generic
-rw-r--r-- 1 root root  1402187 2007-12-22 16:38 vmlinuz-2.6.18-5-alpha-generic
-rw-r--r-- 1 root root  1587497 2012-03-04 18:22 vmlinuz-2.6.26-2-alpha-generic
-rw-r--r-- 1 root root  1915253 2011-08-10 15:49 vmlinuz-2.6.32-bpo.5-alpha-generic
lrwxrwxrwx 1 root root       34 2012-07-10 00:18 vmlinuz.new -> vmlinuz-2.6.32-bpo.5-alpha-generic

% cat /boot/etc/aboot.conf
# aboot default configurations
0:2/vmlinuz ro initrd=/initrd.img root=/dev/sdb3
1:2/vmlinuz.new ro initrd=/initrd.img.new root=/dev/sdb3

At srm:

 >>> b -fl 0 dke900 -- works
 >>> b -fl 1 dke900 -- fails

The failure is right after the message "aboot: loading compressed vmlinuz.new...".

On other news, the ds20 showed up today and I am hoping to have it online
by the end of the week.

Thanks for you help,


So, with debootstrap from lenny-backports and the updated kernels maybe
you will have better luck.  As soon as you get booted into the unstable
kernel I would be looking to update the kernel to that of the unstable
distribution (currently 3.2.21-3).  The generic kernel from unstabel
works fine however the SMP kernel still has some serious teething problems.



Bill MacAllister
Infrastructure Delivery Group, Stanford University

Reply to: