[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Using debootstrap to install from Debian-Ports [was Re: qLogic and wheezy]

--On Sunday, June 17, 2012 09:22:38 PM +1200 Michael Cree <mcree@orcon.net.nz> wrote:

On 15/06/12 09:35, Michael Cree wrote:
And, yes, there is an alternative:

Use debootstrap from a working computer to install straight to unstable.

I meant to write up instructions on how to do that at the alphalinux

Done, instructions are at the AlphaLinux wiki:




Thanks for this write up.  I have been working through these
instructions and hit a couple bumps ending in a road block.  I am
using a PWS running lenny with a 2.6.18-5-alpha-generic kernel.  Bumps

* The debootstrap on lenny does not support the --private-key switch.
 The command I used was:

    # debootstrap sid /mnt http://ftp.debian-ports.org/debian

* The boot strap failed at the point it tried to enter the chroot with:

* The proc mount command should use '-t proc'.  The command I used

    # mount proc /mnt/proc/ -t proc

* The directory /dev/pts was not created in the new root.  I created it
 with the command below and mounted it using the documented mount

    # mkdir /mnt/dev/pts

* When I tried to enter the chroot I got the error:

    # LANG=C chroot /mnt /bin/bash
    ... lots of validating ...
    ... lots of extracting ...
    I: Extracting zlib1g...
    W: Failure trying to run: chroot /mnt mount -t proc proc /proc

* Then when I attempted to enter the chroot I hit the road block.

    # LANG=C chroot /mnt /bin/bash
    FATAL: kernel too old

* Then I tried it upgrade the lenny kernel with the kernel from
 http://www2.phys.waikato.ac.nz/~cree/.  When I try and boot that
 kernel I get the error:

    halt code = 2
    kernel stack not valid halt
    PC = 200000000

I did some poking around and saw this problem mentioned a while ago, but
I don't see anything recent.

What should I try next?



Bill MacAllister
Infrastructure Delivery Group, Stanford University

Reply to: