[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Using debootstrap to install from Debian-Ports [was Re: qLogic and wheezy]

On 09/07/12 10:36, Bill MacAllister wrote:
> --On Sunday, June 17, 2012 09:22:38 PM +1200 Michael Cree
> <mcree@orcon.net.nz> wrote:
>>> And, yes, there is an alternative:
>>> Use debootstrap from a working computer to install straight to unstable.
>> Done, instructions are at the AlphaLinux wiki:
>> http://www.alphalinux.org/wiki/index.php/DebianInstall
> Thanks for this write up.  I have been working through these
> instructions and hit a couple bumps ending in a road block.  I am
> using a PWS running lenny with a 2.6.18-5-alpha-generic kernel.

A Lenny kernel will definitely not be sufficient.  Unfortunately neither
will the lenny-backports kernel suffice on Alpha, mainly because of many
missing syscalls.

> * The debootstrap on lenny does not support the --private-key switch.

The Lenny debootstrap might be problematic.  I used the debootstrap from
lenny-backports -- I see that I have version 1.0.25~bpo50+1 installed in
the Lenny partition.

>  The command I used was:
>     # debootstrap sid /mnt http://ftp.debian-ports.org/debian

which probably needs some extra trickery to get debootstrap to verify
the archive key somehow, of which I did work how to do once but I've now

>     # mount proc /mnt/proc/ -t proc

Thanks, now updated on the wiki.

> * The directory /dev/pts was not created in the new root. 

Updated wiki with that.

> * When I tried to enter the chroot I got the error:
>     # LANG=C chroot /mnt /bin/bash
>     ... lots of validating ...
>     ... lots of extracting ...
>     I: Extracting zlib1g...
>     W: Failure trying to run: chroot /mnt mount -t proc proc /proc

I'm not sure what is going on here.

> * Then when I attempted to enter the chroot I hit the road block.
>     # LANG=C chroot /mnt /bin/bash
>     FATAL: kernel too old

Yep, you definitely need a much newer kernel than the Lenny kernel :-(

> * Then I tried it upgrade the lenny kernel with the kernel from
>  http://www2.phys.waikato.ac.nz/~cree/. 

Sorry, but I think those kernels are missing a syscall needed for udev.
 I've just updated them now.

> When I try and boot that
>  kernel I get the error:
>     halt code = 2
>     kernel stack not valid halt
>     PC = 200000000

I've never seen that error before.

So, with debootstrap from lenny-backports and the updated kernels maybe
you will have better luck.  As soon as you get booted into the unstable
kernel I would be looking to update the kernel to that of the unstable
distribution (currently 3.2.21-3).  The generic kernel from unstabel
works fine however the SMP kernel still has some serious teething problems.


Reply to: